Bug 1151901 - Should also add a field for directory files when run virt-ls with --csv option
Summary: Should also add a field for directory files when run virt-ls with --csv option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libguestfs
Version: 6.6
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1151900
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-13 02:35 UTC by Lingfei Kong
Modified: 2015-07-22 05:55 UTC (History)
8 users (show)

Fixed In Version: libguestfs-1.20.11-12.el6
Doc Type: Enhancement
Doc Text:
The output of the "virt-ls --csv --checksum" command now always includes a field for the checksum value, even if the field is empty, like in the case of directories. As a result, the command's output is more easily parseable.
Clone Of: 1151900
Environment:
Last Closed: 2015-07-22 05:55:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1444 normal SHIPPED_LIVE libguestfs bug fix and enhancement update 2015-07-20 18:44:02 UTC

Description Lingfei Kong 2014-10-13 02:35:21 UTC
+++ This bug was initially created as a clone of Bug #1151900 +++

Description of problem:
Should also add a field for directory files when run virt-ls with --csv option
All lines in a csv file should have the same number of fields.


Version-Release number of selected component (if applicable):
libguestfs-1.27.62-1.1.el7


How reproducible:
100%


Steps to Reproduce:
#virt-ls -a rhel.img /etc -Rl --csv --checksum


Actual results:
.....
d,0755,4096,/etc/yum.repos.d
-,0644,529,16dfc405ffa10c1853c5a3271fdb2758,/etc/yum.repos.d/rhel-source.repo
-,0644,138,a680b678bcd7c6dd386ddf0f86633c00,/etc/yum.repos.d/rhel6.repo


Expected results:
.....
d,0755,4096,,/etc/yum.repos.d
-,0644,529,16dfc405ffa10c1853c5a3271fdb2758,/etc/yum.repos.d/rhel-source.repo
-,0644,138,a680b678bcd7c6dd386ddf0f86633c00,/etc/yum.repos.d/rhel6.repo


Additional info:

Comment 3 Hu Zhang 2014-12-10 10:13:09 UTC
Verified with the Package Version:
libguestfs-1.20.11-12.el6.x86_64

Verify steps:
1.virt-ls -a rhel.img /etc -Rl --csv --checksum
...
d,0755,4096,,/etc/yum
d,0755,6,,/etc/yum/fssnap.d
d,0755,102,,/etc/yum/pluginconf.d
...

A new field for directory files is added.

Verified.

Comment 6 errata-xmlrpc 2015-07-22 05:55:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1444.html


Note You need to log in before you can comment on or make changes to this bug.