Bug 115193 - undefined code & 2 * printf problems
Summary: undefined code & 2 * printf problems
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: nss_ldap   
(Show other bugs)
Version: 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-08 10:53 UTC by d.binderman
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-22 04:56:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description d.binderman 2004-02-08 10:53:51 UTC
Description of problem:

I just tried to compile package nss_ldap-207-3 from Fedora.

The compiler said

1.

../db_load/db_load.c:810: warning: operation on `instr' may be undefined

The source code is

                        c = digitize(dbenv, *instr, &e1) << 4 |
                            digitize(dbenv, *++instr, &e2);

Better source code is

                        c = digitize(dbenv, instr[ 0], &e1) << 4 |
                            digitize(dbenv, instr[ 1], &e2);
                        ++instr;

2.

pam_ldap.c(2594): warning #268: the format string ends before this
argument

The source code is

      ber_printf (ber, "ts", LDAP_TAG_EXOP_MODIFY_PASSWD_ID,
                  session->info->userdn);

I'm not sure what the fix is for this. It looks like
LDAP_TAG_EXOP_MODIFY_PASSWD_ID is some fixed constant.

3.

pam_ldap.c(2598): warning #268: the format string ends before this
argument

The source code is

      ber_printf (ber, "ts", LDAP_TAG_EXOP_MODIFY_PASSWD_NEW,
new_password);

Duplicate.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 John Thacker 2006-04-22 04:56:06 UTC
Not going to patch upstream code to quiet a compiler warning rather than fix a
bug or error.


Note You need to log in before you can comment on or make changes to this bug.