Bug 1151943 - Do not use 'mock --shell' for non-interactive scripts
Summary: Do not use 'mock --shell' for non-interactive scripts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-review
Version: rawhide
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
Assignee: Stanislav Ochotnicky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1185672 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-13 07:09 UTC by Miroslav Suchý
Modified: 2015-02-23 08:03 UTC (History)
6 users (show)

Fixed In Version: fedora-review-0.5.2-2.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-26 02:35:38 UTC
Type: Bug


Attachments (Terms of Use)
Proposed patch to resolve this issue (3.79 KB, patch)
2015-01-15 10:09 UTC, Miroslav Suchý
no flags Details | Diff

Description Miroslav Suchý 2014-10-13 07:09:52 UTC
Do not use 'mock --shell' for non-interactive scripts as it will stop working in feature.

See http://miroslav.suchy.cz/blog/archives/2014/10/12/big_changes_in_mock/index.html

Comment 1 Miroslav Suchý 2015-01-15 10:07:47 UTC
Additonally passing mock --shell foo --someopt will evaluate --someopt as argument to mock. And unless you want shell expansion it is better to use --chroot.
So you should either
  mock --chroot 'foo --someopt'
or
  mock --chroot -- foo --someopt

And btw current code does not work with mock, so I'm raising Priority

Comment 2 Miroslav Suchý 2015-01-15 10:09:02 UTC
Created attachment 980402 [details]
Proposed patch to resolve this issue

Comment 3 Stanislav Ochotnicky 2015-01-19 16:26:30 UTC
I have applied the patch to upstream (thanks!). Had to fix a few other test cases failing but that's all set so I'll have a look at updated packages.

Comment 4 Fedora Update System 2015-01-20 09:18:54 UTC
fedora-review-0.5.2-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/fedora-review-0.5.2-2.fc20

Comment 5 Fedora Update System 2015-01-20 09:18:59 UTC
fedora-review-0.5.2-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/fedora-review-0.5.2-2.fc21

Comment 6 Fedora Update System 2015-01-20 09:19:04 UTC
fedora-review-0.5.2-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/fedora-review-0.5.2-2.el6

Comment 7 Fedora Update System 2015-01-21 23:00:49 UTC
Package fedora-review-0.5.2-2.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedora-review-0.5.2-2.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-0974/fedora-review-0.5.2-2.fc21
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2015-01-26 02:35:38 UTC
fedora-review-0.5.2-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Miroslav Suchý 2015-01-26 08:02:41 UTC
*** Bug 1185672 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2015-02-23 08:03:21 UTC
fedora-review-0.5.2-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.