Bug 1152028 - WebUI: Product missing in "Red Hat Repositories"
Summary: WebUI: Product missing in "Red Hat Repositories"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.0.4
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: jcallaha
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-13 11:14 UTC by Benjamin
Modified: 2019-09-25 21:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:45:31 UTC
Target Upstream Version:


Attachments (Terms of Use)
Satellite 6.1.1: Red Hat Repositories - Other tab (103.75 KB, image/png)
2015-09-09 18:48 UTC, Brad Buckingham
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Benjamin 2014-10-13 11:14:43 UTC
Description of problem:
I cannot see "Red Hat Software Collections for RHEL Server" in the WebUI amongst other to add the Repository to be able to sync the content. My guess is that the products are limited to a certain amount of Products.

Version-Release number of selected component (if applicable):
6.0.4

How reproducible:
Add enough Subscriptions to have > X Products available to choose from.

Actual results:
missing Products to enable

Expected results:
Seeing all available Products in WebUI

Additional info:
workaround is to enable the repository via hammer cli:
hammer> repository-set enable --organization-label "soe" --product-id "74" --name "Red Hat Software Collections RPMs for Red Hat Enterprise Linux 7 Server" --releasever "7Server" --basearch "x86_64"
Repository enabled

Comment 1 RHEL Program Management 2014-10-13 11:23:11 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Brad Buckingham 2015-09-09 18:47:26 UTC
I have tested this on a Satellite 6.1.1 GA install and am no longer observing
the behavior described.

RPMs installed:
  ruby193-rubygem-katello-2.2.0.66-1.el7sat.noarch
  foreman-1.7.2.34-1.el7sat.noarch

Attaching screenshot showing the 'Other' tab on Content -> Red Hat Repositories.

Comment 4 Brad Buckingham 2015-09-09 18:48:20 UTC
Created attachment 1071894 [details]
Satellite 6.1.1: Red Hat Repositories - Other tab

Comment 5 jcallaha 2015-10-29 18:16:14 UTC
Verified in upstream. Have attempted to reproduce the error 10 times. Each was unable to encounter the issue. 

 HOSTNAME: rhsm-qe-1.rhq.lab.eng.bos.redhat.com
       OS: redhat
  RELEASE: Red Hat Enterprise Linux Server release 7.1 (Maipo)
  FOREMAN: 1.11.0-develop
     RUBY: ruby 2.0.0p598 (2014-11-13) [x86_64-linux]
   PUPPET: 3.8.3
  DENIALS: 0

Comment 8 errata-xmlrpc 2016-07-27 08:45:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.