Bug 11521 - Dependance of initscripts-5.00-1 on procps-2.0.6-5
Dependance of initscripts-5.00-1 on procps-2.0.6-5
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.2
All Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-19 06:20 EDT by Konrad Gawrys
Modified: 2014-03-16 22:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-22 14:17:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Konrad Gawrys 2000-05-19 06:20:20 EDT
First of all a short note: this problem shows up only when you update some
packages manually.

I only upgraded initscripts package from RH 6.2, procps remained the same
from RH 6.1 (2.0.4-2). But since new initscripts take advantage of sysctl,
the script /etc/rc.d/init.d/network was not able to set up system
parameters properly.

After running sysctl manually, the following error message showed up:

# sysctl -p /etc/sysctl.conf
error: unable to open preload file '/etc/sysctl.conf'

Upgrade to procps-2.0.6-5 solved the problem.

It would be much better, however, if there was a specific requirement to
have the right version of procps.
Comment 1 Bill Nottingham 2000-05-22 14:17:59 EDT
The initial requirement was for procps >= 2.0.4, since
that's where the sysctl program first *appeared*. However,
it wasn't fixed right until 2.0.6-5, so that is probabyl
a better requirement.

Will be fixed in 5.14-1.

Note You need to log in before you can comment on or make changes to this bug.