Bug 115213 - RPC call pmap_unset fails when 32bit binary is run on ia64
RPC call pmap_unset fails when 32bit binary is run on ia64
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: libc (Show other bugs)
7.2
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-09 00:18 EST by Chinmaya
Modified: 2007-04-18 13:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-09 11:17:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chinmaya 2004-02-09 00:18:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Linux 2.4.18-14 i686) 
Opera 7.11  [en]

Description of problem:
RPC server and client programs  built on i686 platform. When these 
programs were on RH7.2 ia64 m/c the server program fails on the rpc 
call 'pmap_unset' with the error "__get_myaddress: ioctl: No such 
device". The the rpc function "get_myaddress" fails with the same 
error.
When this program is run through strace it was found that the failure 
was due to the ioctl call 
 ioctl(3, SIOCGIFFLAGS, 0xbfffd908)      = -1 ENODEV (No such device)

HOWEVER the same program when built as a 64 bit application the 
problem does not occur.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Write a program with calls to pmap_unset or get_myaddress
2.Build this program on a 32 bit machine
3.Run this application on a ia64 machine with RH 7.2 installed

The applications fails with eror _get_myaddress: ioctl: No such 
device
    

Actual Results:  The applications fails with eror _get_myaddress: 
ioctl: No such device

Expected Results:  The error should not be seen.

Additional info:
Comment 1 Jakub Jelinek 2004-02-09 11:17:52 EST
RHL 7.2 is not supported anymore.  Furthermore that sounds like 32-bit
syscall support problem on the kernel side, not glibc.

Note You need to log in before you can comment on or make changes to this bug.