Bug 115218 - Laptop LCD backlight doesn't turn off on ATI Radeon chips
Laptop LCD backlight doesn't turn off on ATI Radeon chips
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
http://michaelo.free.fr/contrib/radeo...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-09 03:48 EST by Péter, Soós
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-18 04:17:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Péter, Soós 2004-02-09 03:48:27 EST
Description of problem:

My laptop contains an ATI Radeon Mobility 7500 graphics card.

This card is supposed to be supported with Xfree86 4.3, but I can't
manage to switch the screen off:

> xset -display :0 dpms force off

The screen gets black, but not switched off (backlighting is still on).

Version-Release number of selected component (if applicable):
XFree86-4.3.0-42

How reproducible:
Always

Steps to Reproduce:
1. xset -display :0 dpms force off
2.
3.
  
Actual results:
The screen gets black, but not switched off (backlighting is still on).

Expected results:
The LCD panel backlight turns off.

Additional info:
There is a solution for this problem in the XFree86 CVS. See
http://michaelo.free.fr/contrib/radeon/poweroff.php3 for details.
Comment 1 Mike A. Harris 2004-02-09 04:13:24 EST
This isn't a bug really, the XFree86 4.3.0 driver just does not
support this 'feature' of the Radeon hardware.  While the current
CVS code does support it, none of the links on the bug report
nor the URL you provided contain a _proper_ minimal unified
diff to add this support to the driver.

The patch referenced in the bug report is a series of things
committed to CVS all in one shot, and does not actually have
a link to the patch.  I'd have to manually dig this out of
CVS myself.  While I don't mind doing that, it is a low priority
since it is for adding a new feature rather than fixing a bug.

So I'll leave this open for now until I have time to dig the
patch out of CVS and review it, backport it to 4.3.0 and have
it tested.  If anyone is interested in having this happen sooner
rather than later, they're welcome to poke through XFree86
CVS and backport the patch themselves and attach it to the
bug report.  That would speed things up.

Comment 2 Warren Togami 2004-02-29 03:26:51 EST
I just realized I have this problem too on my IBM Thinkpad T41. 
Adding this to my TODO list.
Comment 3 Warren Togami 2004-03-18 04:17:22 EST
The move from XFree86-4.3.0 to xorg-x11 in rawhide solved this problem!

Note You need to log in before you can comment on or make changes to this bug.