Bug 115229 - ccm load (or config registry?) swallows root cause errors
Summary: ccm load (or config registry?) swallows root cause errors
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Web Application Framework
Classification: Retired
Component: installation   
(Show other bugs)
Version: nightly
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Dennis Gregorovic
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-09 13:28 UTC by Daniel Berrange
Modified: 2007-04-18 17:02 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-12 16:51:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Berrange 2004-02-09 13:28:22 UTC
Description of problem:
Run ccm load on a filesystem where /etc is 100% full. It just says 
unable to create directory: /usr/share/ccm/conf/ccm-ldn-atoz without
giving an explanation of why. It should report the root cause which is
that the filesystem was full.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Make /etc 100% full
2. Run ccm load
3.
  
Actual results:
unable to create directory: /usr/share/ccm/conf/ccm-ldn-atoz


Expected results:
unable to create directory: /usr/share/ccm/conf/ccm-ldn-atoz; Out of
disk space


Additional info:

Comment 1 Dennis Gregorovic 2004-02-09 22:47:29 UTC
How do you find out why the directory creation failed from Java? I
don't see a way.
http://java.sun.com/j2se/1.3/docs/api/java/io/File.html#mkdirs()

Comment 2 Daniel Berrange 2004-02-10 09:47:45 UTC
I had hoped it would throw an IOException with the root cause, but
evidently not :-(

Comment 3 Dennis Gregorovic 2004-02-12 16:51:30 UTC
Marking as won't fix since there is no easy way to ascertain why
directory creation has failed.  


Note You need to log in before you can comment on or make changes to this bug.