Bug 1152350 - Missing dependency for python-oslo-db package
Summary: Missing dependency for python-oslo-db package
Keywords:
Status: CLOSED DUPLICATE of bug 1170724
Alias: None
Product: RDO
Classification: Community
Component: openstack-cinder
Version: Juno
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: Juno
Assignee: Eric Harney
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-14 01:22 UTC by Matt Kassawara
Modified: 2016-04-26 17:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-18 18:26:25 UTC


Attachments (Terms of Use)

Description Matt Kassawara 2014-10-14 01:22:31 UTC
Description of problem: Cinder services need the python-oslo-db package, but the openstack-cinder package does not install it as a dependency.

Version-Release number of selected component (if applicable): openstack-cinder-2014.2-0.2.b3

How reproducible: Consistent.

Steps to Reproduce:

1. Install cinder using the openstack-cinder package.
2. Configure cinder.
3. Attempt to start any of the cinder services (e.g., cinder-volume).

Actual results: Service fails to start and generates traceback.

Oct 14 00:07:41 hst-os1stg1 systemd: Starting OpenStack Cinder Volume Server...
Oct 14 00:07:41 hst-os1stg1 systemd: Started OpenStack Cinder Volume Server.
Oct 14 00:07:41 hst-os1stg1 cinder-volume: Traceback (most recent call last):
Oct 14 00:07:41 hst-os1stg1 cinder-volume: File "/usr/bin/cinder-volume", line 52, in <module>
Oct 14 00:07:41 hst-os1stg1 cinder-volume: from cinder import service
Oct 14 00:07:41 hst-os1stg1 cinder-volume: File "/usr/lib/python2.7/site-packages/cinder/service.py", line 32, in <module>
Oct 14 00:07:41 hst-os1stg1 cinder-volume: from cinder import db
Oct 14 00:07:41 hst-os1stg1 cinder-volume: File "/usr/lib/python2.7/site-packages/cinder/db/__init__.py", line 20, in <module>
Oct 14 00:07:41 hst-os1stg1 cinder-volume: from cinder.db.api import *  # noqa
Oct 14 00:07:41 hst-os1stg1 cinder-volume: File "/usr/lib/python2.7/site-packages/cinder/db/api.py", line 45, in <module>
Oct 14 00:07:41 hst-os1stg1 cinder-volume: from oslo.db import concurrency as db_concurrency
Oct 14 00:07:41 hst-os1stg1 cinder-volume: ImportError: No module named db

Expected results: Service starts successfully.

Additional info: None.

Comment 1 Eric Harney 2015-03-18 18:26:25 UTC

*** This bug has been marked as a duplicate of bug 1170724 ***


Note You need to log in before you can comment on or make changes to this bug.