Bug 1152404 - flags description of blkdeviotune command is wrong
Summary: flags description of blkdeviotune command is wrong
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.1
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Peter Krempa
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-14 05:42 UTC by Pei Zhang
Modified: 2015-11-19 05:53 UTC (History)
6 users (show)

Fixed In Version: libvirt-1.2.13-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 05:53:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2202 0 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2015-11-19 08:17:58 UTC

Description Pei Zhang 2014-10-14 05:42:32 UTC
description of problem:
There is one typo in flag description of blkdeviotune man page,
"Both --live and --current flags may be given" should be "Both --live and --config flags may be given".

Version:
libvirt-1.2.8-5.el7.x86_64

How reproducible:
100%

Steps to Reproduce:

1.
#man virsh

 blkdeviotune domain device [[--config] [--live] | [--current]] [[total-bytes-sec] | [read-bytes-sec] [write-bytes-sec]]
       [[total-iops-sec] | [read-iops-sec] [write-iops-sec]]
.........

 Both --live and --current flags may be given, but --current
           is exclusive. If no flag is specified, behavior is different depending on hypervisor.

2.
check another command like 'blkiotune':

 Both --live and --config flags may be given, but --current
           is exclusive. If no flag is specified, behavior is different depending on hypervisor.


Actual results:
In step 1, the "Both --live and --current flags may be given" is wrong,

Expected results:
In step 1, it should be "Both --live and --config flags may be given" like which one in step 2.

Comment 2 Peter Krempa 2014-10-14 07:53:01 UTC
Fixed upstream:

commit 59de544f6a1a8d022a15993c9bd026b0c3a12f22
Author: Peter Krempa <pkrempa@redhat.com>
Date:   Tue Oct 14 09:41:24 2014 +0200

    virsh: man: Fix description of --live/--config usage
    
    dommemstat and blkdeviotune's man page incorrectly stated the usage of
    --live and --config.

Comment 4 yisun 2015-03-27 07:45:20 UTC
Verified, 
Versions:
# rpm -qa | grep libvirt-1
libvirt-1.2.13-1.el7.x86_64


steps:
1. man virsh
2. search /blkdeviotune
3. check the modified doc segment. As follow: 
If --live is specified, affect a running guest.  If --config is specified, affect the next boot of a persistent guest.  If --current is
           specified, affect the current guest state.  When setting the disk io parameters both --live and --config flags may be given, but
           --current is exclusive. For querying only one of --live, --config or --current can be specified. If no flag is specified, behavior is
           different depending on hypervisor.

Comment 6 errata-xmlrpc 2015-11-19 05:53:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2202.html


Note You need to log in before you can comment on or make changes to this bug.