Bug 1152473 - run net-dhcp-leases command in quiet mode cannot get any output
Summary: run net-dhcp-leases command in quiet mode cannot get any output
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.1
Hardware: x86_64
OS: All
low
low
Target Milestone: rc
: ---
Assignee: Libvirt Maintainers
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-14 08:54 UTC by Luyao Huang
Modified: 2015-11-19 05:54 UTC (History)
5 users (show)

Fixed In Version: libvirt-1.2.13-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 05:54:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2202 0 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2015-11-19 08:17:58 UTC

Description Luyao Huang 2014-10-14 08:54:01 UTC
Description of problem:
run net-dhcp-leases command in quiet mode cannot get any output


Version-Release number of selected component (if applicable):
libvirt-1.2.8-5.el7.x86_64


How reproducible:
100%

Steps to Reproduce:

1.# virsh  net-dhcp-leases default
 Expiry Time          MAC address        Protocol  IP address                Hostname        Client ID or DUID
-------------------------------------------------------------------------------------------------------------------
 2014-10-13 14:45:09  00:22:44:66:88:aa  ipv4      192.168.122.48/24         -               -

2.# virsh  -q net-dhcp-leases default
                                       <------no output

Actual results:
run net-dhcp-leases command in quiet mode cannot get any output

Expected results:

# virsh  -q net-dhcp-leases default
 2014-10-13 14:45:09  00:22:44:66:88:aa  ipv4      192.168.122.48/24  

Additional info:

from man virsh:
       -q, --quiet
           Avoid extra informational messages.

Comment 1 Luyao Huang 2014-11-04 00:24:58 UTC
Send a patch to upstream:

https://www.redhat.com/archives/libvir-list/2014-November/msg00002.html

Comment 2 Ján Tomko 2015-01-26 17:02:13 UTC
Fixed upstream by:
commit ff071bc8b29c5442a080be0cd367e82286bdbcd3
Author:     Luyao Huang <lhuang@redhat.com>
AuthorDate: 2014-11-01 18:41:20 +0800
Commit:     Martin Kletzander <mkletzan@redhat.com>
CommitDate: 2014-11-06 15:13:55 +0100

    virsh: fix net-dhcp-leases no output in quiet mode
    
    When run net-dhcp-leases in quiet mode, cannot get
    any output.
    
     # virsh -q net-dhcp-leases default
    
    Signed-off-by: Luyao Huang <lhuang@redhat.com>

git describe: v1.2.10-32-gff071bc contains: v1.2.11-rc1~271

Comment 4 hongming 2015-07-06 07:32:28 UTC
Verify it as follows. Move its status to VERIFIED.

# rpm -q libvirt
libvirt-1.2.17-1.el7.x86_64

# virsh  net-dhcp-leases default
 Expiry Time          MAC address        Protocol  IP address                Hostname        Client ID or DUID
-------------------------------------------------------------------------------------------------------------------
 2015-07-06 16:26:07  52:54:00:68:ce:60  ipv4      192.168.122.104/24        -               -


# virsh  -q net-dhcp-leases default
 2015-07-06 16:26:07  52:54:00:68:ce:60  ipv4      192.168.122.104/24        -               -

# virsh --quiet net-dhcp-leases default
 2015-07-06 16:26:07  52:54:00:68:ce:60  ipv4      192.168.122.104/24        -               -

Comment 6 errata-xmlrpc 2015-11-19 05:54:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2202.html


Note You need to log in before you can comment on or make changes to this bug.