Bug 115261 - mgetty shouldn't use acroread
mgetty shouldn't use acroread
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: mgetty (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-09 15:04 EST by Jonathan Kamens
Modified: 2007-04-18 13:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-20 14:25:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
try level 1 postscript if level 2 fails (544 bytes, patch)
2004-02-11 08:49 EST, Jonathan Kamens
no flags Details | Diff

  None (edit)
Description Jonathan Kamens 2004-02-09 15:04:51 EST
I recently attempted to send a PDF file by fax with mgetty-1.1.30-5 
using the faxspool command.  /usr/bin/faxspool uses acroread -
toPostScript to convert pdf to ps.  Unfortunately, when acroread 
converted this particular file to PS, the resulting PS file couldn't 
be read by gs -- attempts to do so produced an error.

I see no reason to use acroread, a non-free program which produces 
apparently defective ps, when modern versions of gs can read pdf 
files directly.  I modified faxspool to change fs_cvt_pdf to this, 
and everything seemed to work fine:

fs_cvt_pdf()
{
    fs_cvt_ps "$@"
}
Comment 1 Jonathan Kamens 2004-02-11 08:48:27 EST
I don't think the fix I submitted before is the best one.  Acroread
actually produces much better PostScript from a PDF file than gs does,
so it's preferable to use acroread whenever possible.  In the case I
encountered when acroread produced PostScript that gs couldn't
interpret, I found that telling acroread to generate PostScript level
1 instead of level 2 worked around this problem.  However we don't
want to generate level 1 all the time because it's slower and bigger.
 So the patch which I will attach momentarily tries level 2 and if
that fails falls back on level 1.
Comment 2 Jonathan Kamens 2004-02-11 08:49:03 EST
Created attachment 97582 [details]
try level 1 postscript if level 2 fails
Comment 3 Jason Vas Dias 2004-08-20 14:25:14 EDT
Now fixed in mgetty-1.1.31-2 

Note You need to log in before you can comment on or make changes to this bug.