Bug 1152753 - IOError: [Errno 2] Bestand of map bestaat niet: '/mnt/sysimage/etc/yum/pluginconf.d/langpacks.conf'
Summary: IOError: [Errno 2] Bestand of map bestaat niet: '/mnt/sysimage/etc/yum/plugin...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:122310ef7d0da9aaf9e87942f5b...
: 1166932 1173419 1177792 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-14 21:05 UTC by harry
Modified: 2015-11-06 01:15 UTC (History)
10 users (show)

Fixed In Version: anaconda-22.19-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-06 01:15:46 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (762.37 KB, text/plain)
2014-10-14 21:05 UTC, harry
no flags Details
File: anaconda.log (24.94 KB, text/plain)
2014-10-14 21:05 UTC, harry
no flags Details
File: environ (459 bytes, text/plain)
2014-10-14 21:05 UTC, harry
no flags Details
File: lsblk_output (2.70 KB, text/plain)
2014-10-14 21:05 UTC, harry
no flags Details
File: nmcli_dev_list (1.60 KB, text/plain)
2014-10-14 21:05 UTC, harry
no flags Details
File: os_info (381 bytes, text/plain)
2014-10-14 21:05 UTC, harry
no flags Details
File: program.log (47.74 KB, text/plain)
2014-10-14 21:05 UTC, harry
no flags Details
File: storage.log (278.34 KB, text/plain)
2014-10-14 21:05 UTC, harry
no flags Details
File: syslog (183.86 KB, text/plain)
2014-10-14 21:05 UTC, harry
no flags Details
File: ifcfg.log (1.93 KB, text/plain)
2014-10-14 21:05 UTC, harry
no flags Details
File: packaging.log (140.86 KB, text/plain)
2014-10-14 21:05 UTC, harry
no flags Details

Description harry 2014-10-14 21:05:23 UTC
Description of problem:
Installing from boot.iso rawhide, the installer (anaconda ?) has an unknown error during installing bootloader. the result is that with the NEW bootloader I can choose fedora installation but cannot login (probably because users/passwords are not set after failing bootloader installation)

Version-Release number of selected component:
anaconda-22.8-1

The following was filed automatically by anaconda:
anaconda 22.8-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/shutil.py", line 83, in copyfile
    with open(dst, 'wb') as fdst:
  File "/usr/lib64/python2.7/shutil.py", line 130, in copy2
    copyfile(src, dst)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 258, in _copyLangpacksConfigToTarget
    iutil.getSysroot()+_yum_target_langpack_conf)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1524, in postInstall
    self._copyLangpacksConfigToTarget()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 262, in doInstall
    payload.postInstall()
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in run
    threading.Thread.run(self, *args, **kwargs)
IOError: [Errno 2] Bestand of map bestaat niet: '/mnt/sysimage/etc/yum/pluginconf.d/langpacks.conf'

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-rawhide-x86_64 quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.18.0-0.rc0.git6.1.fc22.x86_64
product:        Fedora"
release:        Cannot get release name.
type:           anaconda
version:        Fedora

Comment 1 harry 2014-10-14 21:05:31 UTC
Created attachment 947036 [details]
File: anaconda-tb

Comment 2 harry 2014-10-14 21:05:32 UTC
Created attachment 947037 [details]
File: anaconda.log

Comment 3 harry 2014-10-14 21:05:33 UTC
Created attachment 947038 [details]
File: environ

Comment 4 harry 2014-10-14 21:05:34 UTC
Created attachment 947039 [details]
File: lsblk_output

Comment 5 harry 2014-10-14 21:05:36 UTC
Created attachment 947040 [details]
File: nmcli_dev_list

Comment 6 harry 2014-10-14 21:05:37 UTC
Created attachment 947041 [details]
File: os_info

Comment 7 harry 2014-10-14 21:05:38 UTC
Created attachment 947042 [details]
File: program.log

Comment 8 harry 2014-10-14 21:05:42 UTC
Created attachment 947043 [details]
File: storage.log

Comment 9 harry 2014-10-14 21:05:45 UTC
Created attachment 947044 [details]
File: syslog

Comment 10 harry 2014-10-14 21:05:46 UTC
Created attachment 947045 [details]
File: ifcfg.log

Comment 11 harry 2014-10-14 21:05:49 UTC
Created attachment 947046 [details]
File: packaging.log

Comment 12 David Shea 2014-11-24 16:42:03 UTC
*** Bug 1166932 has been marked as a duplicate of this bug. ***

Comment 13 Alexander Volovics 2014-12-07 15:04:27 UTC
Another user experienced a similar problem:

during netinstall of rawhide an error warning popped up

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora-rawhide-x86_64 rd.live.check quiet
hashmarkername: anaconda
kernel:         3.18.0-0.rc7.git3.1.fc22.x86_64
package:        anaconda-22.12-1
product:        Fedora"
reason:         IOError: [Errno 2] No such file or directory: '/mnt/sysimage/etc/yum/pluginconf.d/langpacks.conf'
release:        Cannot get release name.
version:        Fedora

Comment 14 David Shea 2014-12-16 19:57:52 UTC
On second thought, I'm going to just leave this one alone. This problem occurs if you 1) use yum during the install, and 2) do not install yum. dnf is now the default in anaconda, and yum will hopefully be removed completely from anaconda in the near future, so for most people this problem has become moot.

Comment 15 David Shea 2014-12-17 14:32:31 UTC
*** Bug 1173419 has been marked as a duplicate of this bug. ***

Comment 16 David Shea 2015-01-05 14:59:18 UTC
*** Bug 1177792 has been marked as a duplicate of this bug. ***

Comment 17 Brian Lane 2015-02-12 23:46:53 UTC
Another user experienced a similar problem:

kickstart with DNF test day boot.iso

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-rawhide-x86_64 inst.proxy=http://proxy.notae.us:8123 inst.ks=http://ks.notae.us/dnf.ks inst.nodnf
hashmarkername: anaconda
kernel:         3.19.0-1.fc22.x86_64
package:        anaconda-22.18-1
product:        Fedora"
reason:         IOError: [Errno 2] No such file or directory: '/mnt/sysimage/etc/yum/pluginconf.d/langpacks.conf'
release:        Cannot get release name.
version:        Fedora

Comment 18 Brian Lane 2015-02-13 00:02:04 UTC
We should make sure yum is in the packageset if yumpayload is used (eg. inst.nodnf).

Comment 19 Martin Bříza 2015-03-01 10:58:36 UTC
Another user experienced a similar problem:

Well, I tried installing F22 using tbe F21 Server Anaconda, since the F22 version is now completely unusable and it failed while installing the bootloader.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora-S-21-x86_64 quiet
hashmarkername: anaconda
kernel:         3.17.4-301.fc21.x86_64
package:        anaconda-21.48.21-1
product:        Fedora"
reason:         IOError: [Errno 2] No such file or directory: '/mnt/sysimage/etc/yum/pluginconf.d/langpacks.conf'
release:        Cannot get release name.
version:        Fedora

Comment 20 Jaroslav Reznik 2015-03-03 17:16:08 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22


Note You need to log in before you can comment on or make changes to this bug.