Bug 115276 - %preun in .spec for distcache causes removal failure
Summary: %preun in .spec for distcache causes removal failure
Status: CLOSED DUPLICATE of bug 110115
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: distcache   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Joe Orton
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-09 23:32 UTC by Chris Van Hoof
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Van Hoof 2004-02-09 23:32:27 UTC
Description of problem:

When removing the distcache rpm on RHEL3 it will fail with chkconfig
usage.


Version-Release number of selected component (if applicable):

Version 0.4.2-3 tested


How reproducible:

Always

Steps to Reproduce:
1. Attempt to remove distcache with rpm -e
2. distcache-devel will need to be removed first or use --nodeps
3.
  
Actual results:

The rpm is not removed and fails.


Expected results:

Full rpm removal.


Additional info:

The failure occurs here:

%preun
if [ $1 = 0 ]; then
        /sbin/service dc_server stop
        /sbin/service dc_client stop
        /sbin/chkconfig --del dc_server dc_client
fi


--del does not take two arguments.  Only one per deletion.  Adding a
new line under corrects the problem:

%preun
if [ $1 = 0 ]; then
        /sbin/service dc_server stop
        /sbin/service dc_client stop
        /sbin/chkconfig --del dc_client
        /sbin/chkconfig --del dc_server
fi

Comment 1 Chris Van Hoof 2004-02-09 23:34:10 UTC
error/usage is as follows:

(root@flux)(502/pts)(06:33pm:02/09/04)-
(#:~)- rpm -e distcache
chkconfig version 1.3.8 - Copyright (C) 1997-2000 Red Hat, Inc.
This may be freely redistributed under the terms of the GNU Public
License.
 
usage:   chkconfig --list [name]
         chkconfig --add <name>
         chkconfig --del <name>
         chkconfig [--level <levels>] <name> <on|off|reset>)
error: %preun(distcache-0.4.2-3) scriptlet failed, exit status 1

Comment 2 Chris Van Hoof 2004-02-09 23:35:18 UTC
Also submitting this through SEG.

Comment 3 Joe Orton 2004-02-10 07:33:05 UTC

*** This bug has been marked as a duplicate of 110115 ***

Comment 4 Red Hat Bugzilla 2006-02-21 19:01:09 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.