Bug 11528 - lilo allows spaces during config of lilo name entry
Summary: lilo allows spaces during config of lilo name entry
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: lilo   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-19 18:39 UTC by Ric Moore
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-06 13:50:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ric Moore 2000-05-19 18:39:31 UTC
During the last part of installation when lilo is set up, and the user is
queried as to what he wants to name the lilo setup, instead of it being the
default word 'linux', they could enter 'linux ric' with a space between the
two words and when booting have lilo barf finding the space. We're seeing
quite a few tickets where the user says it completely installs then refuses
to boot. They'd forget what they named it, while it bombs and we're
supposed to guess what they did because it allowed them to. Ric

Comment 1 rolf_vom_stein 2000-06-06 13:50:41 UTC
During the installation the return code of lilo isn't checked correctly!
If you run  lilo with a blank with a configuration like below: i.e.: 
default = Red Hat
...
   label=Red Hat

Lilo returns: Syntax Error near line XXX

During the installation this error is not handled, thus the 
routine pretends a successful installtion. 


Comment 2 Jeremy Katz 2002-04-12 05:43:46 UTC
fixed in current releases


Note You need to log in before you can comment on or make changes to this bug.