Bug 1152896 - build fails on machine with too many cpu cores
Summary: build fails on machine with too many cpu cores
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: java-1.8.0-openjdk
Version: 6.6
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Andrew John Hughes
QA Contact: Lukáš Zachar
URL:
Whiteboard:
Depends On:
Blocks: 1271375
TreeView+ depends on / blocked
 
Reported: 2014-10-15 07:24 UTC by Tuomo Soini
Modified: 2016-05-10 21:03 UTC (History)
5 users (show)

Fixed In Version: java-1.8.0-openjdk-1.8.0.65-2.b17.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-10 21:03:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
Proposed patch - honor %_smp_ncpus_max (616 bytes, patch)
2014-10-15 07:24 UTC, Tuomo Soini
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0816 normal SHIPPED_LIVE java-1.8.0-openjdk bug fix and enhancement update 2016-05-10 22:39:37 UTC

Description Tuomo Soini 2014-10-15 07:24:28 UTC
Created attachment 947112 [details]
Proposed patch - honor %_smp_ncpus_max

Description of problem:

rebuild of java-1.8.0-openjdk package fails on a machine with big number of cpu cores.

Version-Release number of selected component (if applicable):

java-1.8.0-openjdk-1.8.0.20-3.b26.el6

How reproducible:

Nearly always, the more cores, the more often random build failures happen.

Actual results:

If build machine has 24 cores build always fail with my limited testing (eight tries).

Comment 2 Deepak Bhole 2014-10-15 13:40:42 UTC
Hi, does the build fail without the patch, or does it just not use the right number of cores?

Comment 3 Tuomo Soini 2014-10-15 20:42:57 UTC
Build fails without patch. With patch and %_smp_ncpus_max 8  build works.

This is work-around only, real problem is in openjdk makefiles.

There is no similar problem with java-1.6.0-openjdk or java-1.7.0-openjdk.

Comment 4 Deepak Bhole 2014-10-16 14:30:29 UTC
Ah, so this is just 8-specific. Jiri, please take a look when you get a chance.

Comment 5 Tuomo Soini 2014-10-16 16:07:00 UTC
Did I say it somehow unclearly?

With 8 cores or less there is no problem.

With 24 cores build fails always without patch and number of cores limited.

Comment 6 Deepak Bhole 2014-10-16 16:08:28 UTC
No you were clear. I meant OpenJDK8 specific :)

Comment 11 errata-xmlrpc 2016-05-10 21:03:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0816.html


Note You need to log in before you can comment on or make changes to this bug.