Bug 115290 - nut has read-only config files
nut has read-only config files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nut (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-10 04:14 EST by Milan Kerslager
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-11 18:18:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2004-02-10 04:14:24 EST
The files in /etc/ups directory has very restrictive access rights:

-r--r--r--    1 root     root         3730 Feb 10 10:10 ups.conf
-r--r--r--    1 root     root         1495 Feb 10 09:52 upsd.conf
-r--------    1 root     root         2303 Feb 10 10:02 upsd.users
-r--------    1 nut      nut         11109 Feb 10 10:03 upsmon.conf
-r--------    1 nut      nut          3884 Feb 10 09:52 upssched.conf

Read-only for user nut is Ok as this user is not intended to modify
these files.

Please set write access for root for ups.conf, upsd.conf and upsd.users.
This allows easy edit with no error messages (root is always able to
write to these files anyway).
Comment 1 Ngo Than 2004-02-11 18:18:32 EST
it's fixed in 1.4.1-1, which should be available in rawhide soon

Note You need to log in before you can comment on or make changes to this bug.