Bug 115306 - subversion fails to create any new repository with svnadmin
subversion fails to create any new repository with svnadmin
Status: CLOSED DUPLICATE of bug 91933
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
1
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-10 10:39 EST by Adam Gibson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Gibson 2004-02-10 10:39:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
Subversion does not seem to work with the combination of the i386
glibc(without nptl/tls) and db4.

This is the error I get on an i586 system trying to create a new
repository with svnadmin.

# svnadmin create myrepository
svn: Berkeley DB error while creating environment for filesystem
myrep/db: Invalid argument

It appears to be a problem with db4 not working with subversion with a
non-nptl glibc.  Some people have reported on the subversion
discussion lists that recompiling db4 by replacing the
--enable-posixmutexes switch with --disable-posixmutexes fixes the
problem.  I was able to fix the problem by tweaking the glibc spec
file to allow an i586 build to include nptl/tls and then generating an
glibc i586 target for the modified spec file.  Normally an i586 system
gets the i386(without nptl) version of glibc since there is only an
i386(without nptl) and i686(with nptl) version of glibc in the fedora
core distro.

After changing to an i586 nptl glibc I have not had any problems(This
is on a server without a gui so not apps were tested with the nptl
i586 glibc).

I have even tried upgrading to subversion-0.37 using the RPMs that are
linked to from the official subversion site with the same results.  It
does not work with the non-nptl glibc on i586.  I have not tested on
an 386 (or 486) system but suspect the same problem would exist.






Version-Release number of selected component (if applicable):
subversion-0.32.1-1

How reproducible:
Always

Steps to Reproduce:
1. install fedora core with subversion on an i586 system
2. try to create a repository in your home directory with
# svnadmin create myrepository


    

Actual Results:  An error occurred:

svn: Berkeley DB error while creating environment for filesystem
myrep/db: Invalid argument


Expected Results:  no errors and a full repository created



Additional info:
Comment 1 Joe Orton 2004-02-11 04:49:14 EST

*** This bug has been marked as a duplicate of 91933 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.