Bug 115308 - Evolution crashes on editing To:
Evolution crashes on editing To:
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libgal2 (Show other bugs)
1
All Linux
high Severity high
: ---
: ---
Assigned To: Dave Malcolm
:
: 115248 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-10 10:58 EST by Leonard den Ottolander
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-21 12:10:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash dump of evolution crashing on pressing "To:" in new mail message (120.82 KB, text/plain)
2004-02-10 10:59 EST, Leonard den Ottolander
no flags Details
strace -f of evolution crashing on clicking "To:" in edit new message (206.71 KB, application/octet-stream)
2004-02-10 11:00 EST, Leonard den Ottolander
no flags Details

  None (edit)
Description Leonard den Ottolander 2004-02-10 10:58:00 EST
Description of problem:

I am not sure why this problem suddenly appeared. Before I have seen
evolution crash on shutdown, but I can't remember ever having
experienced this.

Evolution crashes when editing a new mail message and either pressing
the "To:" button or editing the "To:" line. Very annoying. I can now
only mail by replying.

Over the weekend I installed a bunch of -debuginfo rpms, thought this
might be the cause for some reason. But after uninstalling all these
the problem persists.


Version-Release number of selected component (if applicable):

evolution-1.4.5-7


How reproducible:

Currently always. Editing a new message, either press "To:" or edit
the "To:" line.


Actual results:

Evolution segfaults.


Expected results:

Being able to create a new message and edit the "To:" field.
Comment 1 Leonard den Ottolander 2004-02-10 10:59:20 EST
Created attachment 97555 [details]
Crash dump of evolution crashing on pressing "To:" in new mail message
Comment 2 Leonard den Ottolander 2004-02-10 11:00:17 EST
Created attachment 97556 [details]
strace -f of evolution crashing on clicking "To:" in edit new message
Comment 3 Leonard den Ottolander 2004-02-10 11:05:14 EST
*** Bug 115248 has been marked as a duplicate of this bug. ***
Comment 4 Leonard den Ottolander 2004-02-12 14:59:22 EST
According to Gerardo Marin this is a problem with e-table.

Looking at e_table_sorter_new in gal-0.24/gal/e-table/e-table-sorter.c
I am not sure if the problem lies in that function or is GTK related.
Please help me out.
Comment 5 Leonard den Ottolander 2004-03-14 05:57:23 EST
Upstream URL: http://bugzilla.ximian.com/show_bug.cgi?id=54243

Changing component to libgal2.
Comment 6 Leonard den Ottolander 2004-03-30 18:46:44 EST
I did some study of the involved source code. As it turns out there
are no changes whatsoever from libgal2-1.99.10 to libgal2-1.99.11 in
e-table-sorter.[ch].

Changes in glib from 2.2.3 to 2.3.3 do not seem to affect
g_cclosure_marshal_VOID__VOID in gmarshal.[ch]. Also there are no
changes whatsoever in gclosure.[ch].

This leads me to conclude that this issue is not yet solved for FC 2
test 2 either.
Comment 7 Dave Malcolm 2004-05-19 12:40:40 EDT
I believe the problem is in libgal2; do you have the libgal2-debuginfo
package installed? Having a backtrace with full debugging info should
hopefully help to isolate the problem.
Comment 8 Leonard den Ottolander 2004-05-19 17:17:40 EDT
Have a look at comment #1: A backtrace. Comment #2: A strace -f.

Please check the upstream URL mentioned in comment #5 for cross reference.
Comment 9 Leonard den Ottolander 2004-07-08 10:52:46 EDT
A rebuild of libgal2-1.99.11-1 from FC 2 on FC 1 seems to fix this
problem. However this needs the addition of a symlink from
libgal-2.0.so.5 to libgal-2.0.so.6.0.0 and a symlink from
libgal-a11y-2.0.so.5 to libgal-2.0.so.6.0.0. Not sure if this affects
gtkhtml3, but it seems to fix the crashes in evolution.
Comment 10 Leonard den Ottolander 2004-07-08 11:04:31 EDT
Hm. A downgrade to 1.99.10-2 still doesn't give me my old crashes. I
did change the code page to UTF-8 in the mean time. Maybe I should
revert to ISO-8859-15 and see what happens.
Comment 11 John Thacker 2006-04-21 12:10:24 EDT
Since it doesn't seem as though the original reporter can duplicate this
anymore, and evolution doesn't even depend on libgal2 anymore, I'm closing this.
Also, it WORKSFORME in the latest evolution.

Note You need to log in before you can comment on or make changes to this bug.