Bug 1153116 - rubygem-staypuft: Creating a new subnet from within the deployment enforces specifying gateway for networks with no DHCP server.
Summary: rubygem-staypuft: Creating a new subnet from within the deployment enforces ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: unspecified
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: z2
: Installer
Assignee: Imre Farkas
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks: 1108193
TreeView+ depends on / blocked
 
Reported: 2014-10-15 15:55 UTC by Alexander Chuzhoy
Modified: 2016-09-20 05:03 UTC (History)
6 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.4.6-1.el6ost
Doc Type: Bug Fix
Doc Text:
Networks with no DHCP servers are no longer required to have a gateway. This requirement was enforced in previous releases, but has since been removed.
Clone Of:
Environment:
Last Closed: 2014-11-04 17:03:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Alexander Chuzhoy 2014-10-15 15:55:47 UTC
rubygem-staypuft:  Creating a new subnet from within the deployment enforces specifying gateway for networks with no DHCP server.

Environment:

rhel-osp-installer-0.4.4-1.el6ost.noarch
openstack-puppet-modules-2014.1-24.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-foreman-installer-2.0.30-1.el6ost.noarc

Steps to reproduce:
1. Start creating a deployment, advance to "network configuration" page (#2)
2. Click on "New subnet" and select "No existing DHCP" for DHCP server.
3. Fill the network address/name, don't fill the "Gateway" fied and click on "Create subnet".


Result:

The subnet is not created. There's a validation on the gateway field: "can't be blank and is invalid".


Expected result:
Setting the gateway should be optional, so the validation should prevent blank field.

Comment 1 Imre Farkas 2014-10-15 19:34:22 UTC
Not sure if this is a bug, the behavior was specified by the trello card: https://trello.com/c/Lpn3Ce4Y/126-subnets-define-enhancements-for-staypuft-specific-subnet-form

Comment 2 Mike Burns 2014-10-15 20:43:31 UTC
(In reply to Imre Farkas from comment #1)
> Not sure if this is a bug, the behavior was specified by the trello card:
> https://trello.com/c/Lpn3Ce4Y/126-subnets-define-enhancements-for-staypuft-
> specific-subnet-form

The card is incorrect if it says that a gateway is required.  The user/admin needs to be able to specify a gateway if it exists, but should not require one.

Comment 3 Imre Farkas 2014-10-16 07:36:10 UTC
PR: https://github.com/theforeman/staypuft/pull/350

Comment 4 Chris Dearborn 2014-10-16 13:52:40 UTC
Note that if the gateway is not specified then DEFROUTE should be set to "no" in the associated ifcfg file.

Comment 5 Mike Burns 2014-10-16 16:20:09 UTC
(In reply to Chris Dearborn from comment #4)
> Note that if the gateway is not specified then DEFROUTE should be set to
> "no" in the associated ifcfg file.

DEFROUTE gets set to NO on all devices except the Public-API network.  If the Public-api network does not exist on a host, it defaults to the Provisioning network.

Comment 9 Alexander Chuzhoy 2014-10-17 20:24:11 UTC
Verified: 
openstack-foreman-installer-2.0.30-1.el6ost.noarch
rhel-osp-installer-0.4.5-1.el6ost.noarch
openstack-puppet-modules-2014.1-24.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch



Able to create the network without specifying the gateway.

Comment 13 errata-xmlrpc 2014-11-04 17:03:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.