Bug 115348 - No large file support for 32-bit platforms
Summary: No large file support for 32-bit platforms
Keywords:
Status: CLOSED DUPLICATE of bug 123524
Alias: None
Product: Fedora
Classification: Fedora
Component: wget
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-11 00:14 UTC by Ulrich Drepper
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:10 UTC
Type: ---


Attachments (Terms of Use)
Patch to enable large file support (838 bytes, patch)
2004-02-11 00:15 UTC, Ulrich Drepper
no flags Details | Diff

Description Ulrich Drepper 2004-02-11 00:14:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a)
Gecko/20040209

Description of problem:
wget doesn't open files in a way which allows file sizes of > 2GB. 
I'll attach a patch.

Version-Release number of selected component (if applicable):
wget-1.9.1-3

How reproducible:
Always

Steps to Reproduce:
1.add file of >2GB to http server
2.try to download it
3.
    

Actual Results:  writing fails

Expected Results:  writing succeeds

Additional info:

Comment 1 Ulrich Drepper 2004-02-11 00:15:12 UTC
Created attachment 97571 [details]
Patch to enable large file support

Only lightly tested but should work.

Comment 2 Karsten Hopp 2004-02-11 13:08:41 UTC
This has been discussed on the wget-devel mailinglist and the 
solution is not that simple. Just have a look at this code-snippet 
from wget: 
 
/* Sends the SIZE command to the server, and returns the value in 
'size'. 
 * If an error occurs, size is set to zero. */ 
uerr_t ftp_size(struct rbuf *rbuf, const char *file, long int *size) 
 
The whole code needs to be checked for those occurences of long int. 
 
Have a look at  
http://www.mail-archive.com/wget%40sunsite.dk/msg05239.html 
for a dicussion about large files in wget. 
 

Comment 3 Ulrich Drepper 2004-08-26 07:49:18 UTC
Consider adding a variant of the following patch:

http://software.lpetrov.net/wget-LFS/wget-LFS-20040630.patch

I don't know what this strange number_to_string_64 function is
supposed to do, should be correct to replace it with a call to snprintf.

Comment 4 Karsten Hopp 2004-08-26 08:55:26 UTC
I think this function is used to make it work on Windows, should be 
save both ways (to keep or replace it) 

Comment 5 Ulrich Drepper 2004-09-01 06:48:19 UTC

*** This bug has been marked as a duplicate of 123524 ***

Comment 6 Red Hat Bugzilla 2006-02-21 19:01:10 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.