Bug 1153543 - dnf bash completion hangs when trying to complete local path
Summary: dnf bash completion hangs when trying to complete local path
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Igor Gnatenko
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-16 07:53 UTC by Jan Synacek
Modified: 2014-12-13 09:53 UTC (History)
8 users (show)

Fixed In Version: dnf-0.6.3-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-13 09:53:46 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jan Synacek 2014-10-16 07:53:36 UTC
Description of problem:
I have a package (libosmo-dsp-0.3-1.fc22.x86_64.rpm) in my local directory. After typing "dnf install ./lib<TAB><TAB>", bash hangs for a moment. It shouldn't query anything remotely when the path starts with "./".


Version-Release number of selected component (if applicable):
dnf-0.6.2-1.fc22.noarch.rpm
bash-completion-2.1-5.fc21.noarch


Actual results:
Trying to use TAB to complete the package results in a hang.


Expected results:
Tab completion on the local path works instantly.

Comment 1 Parag Nemade 2014-10-16 07:59:54 UTC
This can be a potential duplicate of bug 1151231

Comment 3 Fedora Update System 2014-12-09 14:06:39 UTC
dnf-0.6.3-2.fc21,dnf-plugins-core-0.1.4-1.fc21,hawkey-0.5.2-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-0.6.3-2.fc21,dnf-plugins-core-0.1.4-1.fc21,hawkey-0.5.2-1.fc21

Comment 4 Fedora Update System 2014-12-12 04:32:44 UTC
Package dnf-0.6.3-2.fc21, hawkey-0.5.2-1.fc21, dnf-plugins-core-0.1.4-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.6.3-2.fc21 hawkey-0.5.2-1.fc21 dnf-plugins-core-0.1.4-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-16760/dnf-0.6.3-2.fc21,dnf-plugins-core-0.1.4-1.fc21,hawkey-0.5.2-1.fc21
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-12-13 09:53:46 UTC
dnf-0.6.3-2.fc21, hawkey-0.5.2-1.fc21, dnf-plugins-core-0.1.4-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.