Bug 115364 - kernel upgrade fails to install boot loader
kernel upgrade fails to install boot loader
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-11 09:42 EST by Chris Ricker
Modified: 2014-01-21 17:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-05 13:29:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2004-02-11 09:42:36 EST
The latest kernel errata update fails to detect my bootloader:

I will do the following:
[install: kernel-smp 2.4.22-1.2166.nptl.i686]
Is this ok [y/N]: y
Getting kernel-smp-2.4.22-1.2166.nptl.i686.rpm
kernel-smp-2.4.22-1.2166. 100% |=========================|  13 MB    00:16
Running test transaction:
Test transaction complete, Success!
kernel-smp 100 % done 1/1
Kernel Updated/Installed, checking for bootloader
No bootloader found, Cannot configure kernel, continuing.
Installed:  kernel-smp 2.4.22-1.2166.nptl.i686
Transaction(s) Complete


I'm using grub, and it did update grub.conf (though it left the old
kernel as the default), so I'm not sure where / why I'm getting the
errors:

[root@spamstop root]# cat /boot/grub/grub.conf
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this
file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/hda3
#          initrd /initrd-version.img
#boot=/dev/hda
default=1
timeout=10
splashimage=(hd0,0)/grub/splash.xpm.gz
title Fedora Core (2.4.22-1.2166.nptlsmp)
        root (hd0,0)
        kernel /vmlinuz-2.4.22-1.2166.nptlsmp ro root=LABEL=/
        initrd /initrd-2.4.22-1.2166.nptlsmp.img
title Fedora Core (2.4.22-1.2149.nptlsmp)
        root (hd0,0)
        kernel /vmlinuz-2.4.22-1.2149.nptlsmp ro root=LABEL=/
        initrd /initrd-2.4.22-1.2149.nptlsmp.img
[root@spamstop root]#
Comment 1 Jeremy Katz 2004-02-11 09:48:38 EST
This is yum, not mkinitrd (new-kernel-pkg leaves the old kernel as the
default and then yum tries to switch it).  What do you get if you
python /usr/share/yum/checkbootloader.py?
Comment 2 Chris Ricker 2004-02-11 10:04:04 EST
Okay, thanks.

[root@spamstop root]# python /usr/share/yum/checkbootloader.pyc
Unable to determine boot loader.
[root@spamstop root]#

Comment 3 Chris Ricker 2004-02-11 10:04:59 EST
I might be mistaken (too many machines, not enough brain cells), but I
don't remember this happening when yum updating from 2115 to 2149....
Comment 4 Chris Ricker 2004-02-11 15:07:13 EST
I just glanced through checkbootloader.py. If I uncomment the print
statement in the "for dev in bootdevs" loop, I get:

[root@spamstop yum-2.0.4]# python checkbootloader.py
checking hda
 
Unable to determine boot loader.
[root@spamstop yum-2.0.4]#

This system is SCSI (hardware RAID):

[root@spamstop yum-2.0.4]# mount | grep ^/
/dev/sda3 on / type ext3 (rw)
/dev/sda1 on /boot type ext3 (rw)
/dev/sdb1 on /var/spool type ext3 (rw)
[root@spamstop yum-2.0.4]#
Comment 5 Jeff Johnson 2004-02-11 17:40:05 EST
NEEDINFO while awaiting patch from upstream (and so I don't
have to stare at this bug).
Comment 6 Chris Ricker 2004-04-26 15:15:52 EDT
Was the yum update to 2.0.5 done in March supposed to fix this? It
didn't, since I still saw the problem when yum put the new 2188 errata
kernel on the system....
Comment 7 Seth Vidal 2004-05-04 22:21:03 EDT
can you post your /etc/grub.conf here?

your /etc/grub.conf has tha

#boot=/dev/hda

the checkbootloader code still looks and uses that to search for
bootloaders.

change that from /dev/hda to /dev/sda and see if everything magically
starts working.

also - I know it's commented out - it doesn't matter.

You should be seeing this behavior from up2date too - it uses the same
code for the bootloader detection.
Comment 8 Chris Ricker 2004-05-05 10:21:20 EDT
Changing it from hda to sda appears to make it work:

[root@spamstop grub]# python /usr/share/yum/checkbootloader.pyc
Found GRUB.
[root@spamstop grub]#

There's no good reason for anaconda to have ever gotten hda in there
in the first place -- that system has always been SCSI, and it was a
fresh install of Fedora Core 1....
Comment 9 Seth Vidal 2004-05-05 13:03:31 EDT
you didn't accidentally copy a grub.conf over from somewhere else or
cut and paste a little liberally, did you?
Comment 10 Chris Ricker 2004-05-05 13:26:43 EDT
Not that I recall, and the only note in the log book was that default
was fixed manually after updates (and now that the comment was changed
from hda to sda)....

If there haven't been any other reports of anaconda generating hda
instead of sda, though, you should probably chalk it up to me doing it
and having forgotten it -- that machine is a bog-standard dell
poweredge 1750, so it's not like it's an unusual configuration
Comment 11 Seth Vidal 2004-05-05 13:29:25 EDT
ok, I'm going to close this one as notabug, for now, unless jeremy
says otherwise.

I'd really prefer it if red hat's bugzilla had a:
Close -> Weird.

:)


Note You need to log in before you can comment on or make changes to this bug.