Bug 115370 - CUPS crashes during runtime
CUPS crashes during runtime
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
1
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-11 11:20 EST by Jason Straw
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.1.23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-20 03:59:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Straw 2004-02-11 11:20:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
I have a network of 24 computers in a University Lab, which all print
through another instance of CUPS on a server.  About one of these
computers a day will stop printing. 

Restarting CUPS on the lab workstation does solve the problem, but
does not keep it from happening again.

Version-Release number of selected component (if applicable):
cups-1.1.19-13

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
I have not figured out how to forcibly reproduce the error, but it
reoccurs every once in a while.



Additional info:

I [11/Feb/2004:11:00:14 -0500] Listening to 7f000001:631
I [11/Feb/2004:11:00:14 -0500] Loaded configuration file
"/etc/cups/cupsd.conf"
I [11/Feb/2004:11:00:14 -0500] Configured for up to 100 clients.
I [11/Feb/2004:11:00:14 -0500] Allowing up to 100 client connections
per host.
I [11/Feb/2004:11:00:14 -0500] Full reload is required.
I [11/Feb/2004:11:00:15 -0500] LoadPPDs: Read "/etc/cups/ppds.dat", 13
PPDs...
I [11/Feb/2004:11:00:15 -0500] LoadPPDs: No new or changed PPDs...
I [11/Feb/2004:11:00:15 -0500] Full reload complete.
E [11/Feb/2004:11:00:15 -0500] StartListening: Unable to bind socket -
Address already in use.
Comment 1 Tim Waugh 2004-02-11 11:25:24 EST
Apply the test updates for redhat-config-printer:

http://www.redhat.com/archives/fedora-test-list/2004-February/msg00231.html

Does the problem still occur after doing that?
Comment 2 David Anderson 2004-02-27 05:16:38 EST
Same problem for me - random crashes which leave nothing in the 
logs. However this is with Red Hat 9. I'm compiling the Fedora RPM 
(without DBUS) to see if the problem goes away with this. 
Comment 3 Tim Waugh 2004-02-27 05:21:47 EST
David: if there is nothing in the logs, it is a *different* problem.

Or do you see the 'Unable to bind socket' message?
Comment 4 David Anderson 2004-02-27 05:25:34 EST
Sorry - you're right, different problem. It just dies, and logs 
nothing in /var/log/cups/* or /var/log/messages. No pattern to it as 
far as I can see. All clients are using CUPS or Adobe postscript 
drivers. 
 
I won't bother to file a new bug if the Fedora RPM works. 
 
 
Comment 5 Marius Andreiana 2005-08-20 03:59:46 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there haven't been any
updates to the report in quite a long time now after we've
requested additional information, we're assuming the problem
is either no longer present in our current OS release, or
that there is no longer any interest in tracking the problem.

Setting status to "CURRENTRELEASE", however if you still
experience this problem after updating to our latest Fedora
Core release and are still interested in Red Hat tracking
the issue, and assisting in troubleshooting the problem,
please feel free to provide the information requested above,
and reopen the report.

Thanks in advance.

Note You need to log in before you can comment on or make changes to this bug.