Bug 115372 - <F12> on text-mode Disk Partitioning Setup screen ALWAYS chooses Autopartition
<F12> on text-mode Disk Partitioning Setup screen ALWAYS chooses Autopartition
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-11 11:34 EST by Glen A. Foster
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-12 17:19:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Glen A. Foster 2004-02-11 11:34:52 EST
Description of problem: Running a TUI install, the anaconda screen
entitled "Disk Partitioning Setup" (where the user is asked how to
partition the drive(s)) advances to Autopartition (e.g., the screen
entitled "Automatic Partitioning" IF YOU USE <F12> to advance to the
next screen.

U/I says (at the bottom of the TUI installer) that <F12> is used to
advance to the next screen.  I have seen many anaconda screens use the
selections made on a screen and advance-via-<F12> but this screen does
not.

In case that's not clear, on the Disk Partitioning Setup screen if you
<TAB> to either "Disk Druid" or "Back" and press <F12> to advance to
the next screen, you get Autopartioning, period.

That seems a bit inconsistent since many other screens honor the
selections made (e.g., text-vs-graphical boot mode in the VGA config
screen, etc.).

Version-Release number of selected component (if applicable):
RHEL3 update 1 is what I'm seeing this on.

How reproducible: 100%
Comment 1 Jeremy Katz 2004-02-12 17:19:17 EST
F12 goes to the next screen with the defaults, not with whatever you
have selected.  Otherwise, hitting F12 with Back selected would go back.

Note You need to log in before you can comment on or make changes to this bug.