Bug 115379 - pcre conflict between httpd and php
pcre conflict between httpd and php
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: httpd (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-11 12:29 EST by Joe Orton
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-23 04:48:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2004-02-11 12:29:44 EST
Duplicate of bug 98056 as this issue also affects Red Hat Enterprise
Linux 3:

Additional Comment #9 From Allen Smith on 2004-02-10 14:00 -------
Private Comment

I am seeing this on a RHEL3 box. httpd-2.0.46-26.ent Doesn't matter if
I run threaded or prefork. It happens whenever I hit a file in the
directory that has rewrite rules in the .htaccess. Only 4 lines of
rewrite rules.

Here is a partial backtrace from gdb.

#66 0x08087419 in pcre_compile ()
#67 0x08087f9f in pcre_compile ()
#68 0x08087960 in pcre_compile ()
#69 0x08087419 in pcre_compile ()
#70 0x08087f9f in pcre_compile ()
#71 0x08087e89 in pcre_compile ()
#72 0x08086256 in pcre_compile ()
#73 0x08088373 in pcre_exec ()
#74 0x08083724 in regexec ()
Comment 1 Allen Smith 2004-02-11 13:26:57 EST
I worked around this by simplifying the regular expressions I was
using. The new regexps work fine on apache2, but fail on our older
boxes (1.3.2x). 
Comment 2 Joe Orton 2004-02-11 14:41:05 EST
Can you give an example .htaccess which failed?
Comment 3 Allen Smith 2004-02-11 14:58:51 EST
sure:
This one fails:

RewriteEngine On
RewriteCond %{HTTP_REFERER}
!^http(s)?://([a-z0-9-]+.)*falconstudios.com/ [NC] RewriteCond
%{HTTP_REFERER} !^http(s)?://([a-z0-9-]+.)*joshweston.com/ [NC]
RewriteCond %{HTTP_REFERER} !^http(s)?://66.28.50.194/ [NC]
RewriteRule /* http://www.falconstudios.com/error.htm [R,L]

This one is fine:
RewriteEngine On
RewriteCond %{HTTP_REFERER}
!^http(s)?://([a-z0-9-.])+falconstudios.com/ [NC] RewriteCond
%{HTTP_REFERER} !^http(s)?://([a-z0-9-.])+joshweston.com/ [NC]
RewriteCond %{HTTP_REFERER} !^http(s)?://66.28.50.194/ [NC]
RewriteRule /* http://www.falconstudios.com/error.htm [R,L]
Comment 4 Joe Orton 2004-02-12 09:21:18 EST
A request with what Referer header will trigger the failure?  We're
having trouble reproducing the problem here.

(the presence of and solution to the bug are clear but we'd like to
find a precise repro case so we can ensure the fix is tested properly)
Comment 5 Allen Smith 2004-02-13 11:22:20 EST
Here is an apache log of a request iwth the source IP stripped.

[13/Feb/2004:08:23:57 -0800] "GET
/pix/EFF1C7B9D3A08/MVP062/Watermarked/Thumbnailed/70/5711_T.jpg
HTTP/1.1" 200 3498
"http://www.falconstudios.com/falconxxx/showGalleryList.do"
"Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) 
Comment 6 Joe Orton 2004-02-26 10:13:27 EST
We couldn't manage to reproduce this problem unfortunately. If you
could try the test update packages in which httpd uses the system pcre
library:

http://people.redhat.com/jorton/Taroon-httpd/

with the example configuration which gave a segfault that would be great.
Comment 7 Mark J. Cox (Product Security) 2004-03-23 04:48:57 EST
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2004-084.html

Note You need to log in before you can comment on or make changes to this bug.