Bug 1153795 - relative-url is not required to be unique
Summary: relative-url is not required to be unique
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Pulp
Classification: Retired
Component: z_other
Version: 2.4.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 2.6.0
Assignee: amacdona@redhat.com
QA Contact: Irina Gulina
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-16 19:08 UTC by Justin Garrison
Modified: 2015-02-28 22:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-28 22:39:54 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Pulp Redmine 580 0 None None None Never

Description Justin Garrison 2014-10-16 19:08:27 UTC
Description of problem: different repos can have the same relative-url


Version-Release number of selected component (if applicable): 2.4.1


How reproducible: Every time


Steps to Reproduce:
1. Create repo with --relative-url
2. create second repo with same relative-url
3. publish both repos

Actual results:
repo that is published last is the one published at the relative url

Expected results:
Checking would prevent setting a relative url that already exists

Additional info:

Comment 1 amacdona@redhat.com 2014-11-11 21:15:52 UTC
Related to this one:

https://bugzilla.redhat.com/show_bug.cgi?id=1079511

Comment 2 amacdona@redhat.com 2014-11-19 19:16:04 UTC
https://github.com/pulp/pulp/pull/1297

This was solved by the PR for BZ1079511, but is not marked as a duplicate because this was a different problem caused by the same code.

Comment 3 Chris Duryee 2014-12-23 20:52:17 UTC
fixed in pulp 2.6.0-0.2.beta

Comment 4 Irina Gulina 2015-01-13 11:24:37 UTC
>> rpm -qa pulp-server
pulp-server-2.6.0-0.2.beta.el6.noarch

>> pulp-admin rpm repo create --repo-id repo1 --relative-url repo --feed https://repos.fedorapeople.org/repos/pulp/pulp/demo_repos/zoo/horse-0.22-2.noarch.rpm
Successfully created repository [repo1]

>> pulp-admin rpm repo create --repo-id repo2 --relative-url repo --feed https://repos.fedorapeople.org/repos/pulp/pulp/demo_repos/zoo/zebra-0.1-2.noarch.rpm

The server indicated one or more values were incorrect. The server provided the
following error message:

   Relative URL [repo] for repository [repo2] conflicts with existing relative
URL [repo] for repository [repo1]

More information can be found in the client log file ~/.pulp/admin.log.

Comment 5 Brian Bouterse 2015-02-28 22:39:54 UTC
Moved to https://pulp.plan.io/issues/580


Note You need to log in before you can comment on or make changes to this bug.