Bug 1153797 - i686 guests on i686 host won't work
Summary: i686 guests on i686 host won't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-16 19:34 UTC by Lubomir Rintel
Modified: 2014-11-10 06:09 UTC (History)
10 users (show)

Fixed In Version: libvirt-1.2.9-4.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-10 06:09:14 UTC
Type: Bug


Attachments (Terms of Use)
libvirtd log (797.85 KB, text/plain)
2014-10-16 19:34 UTC, Lubomir Rintel
no flags Details
Virtual Machine (1.66 KB, text/plain)
2014-10-16 19:34 UTC, Lubomir Rintel
no flags Details

Description Lubomir Rintel 2014-10-16 19:34:17 UTC
Created attachment 947728 [details]
libvirtd log

Description of problem:

i686 guests can't be created.

Version-Release number of selected component (if applicable):

libvirt-daemon-1.2.9-3.fc21.i686

Steps to Reproduce:
1. Just try to install one in virt-manager

Actual results:

Oct 16 20:20:37 goatlord.localdomain libvirtd[574]: Preferred CPU model coreduo not allowed by hypervisor; closest supported model will be used
Oct 16 20:20:37 goatlord.localdomain libvirtd[574]: internal error: Cannot find suitable CPU model for given data

Expected results:

No error.

Additional info:

My machine is a T60 with a coreduo cpu. i486 or anything else won't work either.

Comment 1 Lubomir Rintel 2014-10-16 19:34:53 UTC
Created attachment 947729 [details]
Virtual Machine

Comment 2 Lubomir Rintel 2014-10-16 19:40:13 UTC
I suspected this is due to the aarch64 patch. I downgraded the package to the 1.2.8 version and things started to work. However upon subsequent upgrade it still worked.

Could it be that I had something bad cached in /var/cache/libvirt/qemu/capabilities?

Comment 3 Lubomir Rintel 2014-10-16 19:40:53 UTC
That said, virt-manager still complains, despite it's a different issue now: https://www.redhat.com/archives/libvir-list/2014-October/msg00488.html

Comment 4 Cole Robinson 2014-10-30 14:13:15 UTC
Fixed by:

commit afe8f4200f6e80d2510731165dd2cdae741bd9fb
Author: Lubomir Rintel <lkundrak@v3.sk>
Date:   Thu Oct 16 21:28:00 2014 +0200

    qemu: x86_64 is good enough for i686

Comment 5 Fedora Update System 2014-10-30 16:34:22 UTC
libvirt-1.2.9-4.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/libvirt-1.2.9-4.fc21

Comment 6 Fedora Update System 2014-10-31 01:27:54 UTC
Package libvirt-1.2.9-4.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libvirt-1.2.9-4.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-13990/libvirt-1.2.9-4.fc21
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2014-11-10 06:09:14 UTC
libvirt-1.2.9-4.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.