Bug 1153846 - Redundancy whitespace at the end of directory name when use <TAB> to complete the directory name in guestfish with a xfs filesystem in guest
Summary: Redundancy whitespace at the end of directory name when use <TAB> to complete...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libguestfs
Version: 6.6
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1153844
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-17 00:53 UTC by Lingfei Kong
Modified: 2015-07-22 05:55 UTC (History)
8 users (show)

Fixed In Version: libguestfs-1.20.11-13.el6
Doc Type: Bug Fix
Doc Text:
Using Tab-completion in guestfish on guests with the XFS file system did not correctly append the slash ("/") symbol to directory names. This update adjusts guestfish to properly distinguish files and directories on this file system, and thus fixes the problem.
Clone Of: 1153844
Environment:
Last Closed: 2015-07-22 05:55:45 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1444 normal SHIPPED_LIVE libguestfs bug fix and enhancement update 2015-07-20 18:44:02 UTC

Description Lingfei Kong 2014-10-17 00:53:59 UTC
+++ This bug was initially created as a clone of Bug #1153844 +++

Description of problem:
Redundancy whitespace at the end of directory name when use <TAB> to complete the directory name in guestfish with a xfs filesystem in guest. It works well with ext2/3/4 btrfs filesystem. 


Version-Release number of selected component (if applicable):
libguestfs-tools-c-1.27.63-1.1.el7


How reproducible:
100%


Steps to Reproduce:
#guestfish -N fs:xfs
><fs> mount /dev/sda1 /
><fs> mkdir /test
><fs> ls /test 


Actual results:
><fs> ls /test 

There is a whitespace at the end of /test


Expected results:
><fs> ls /test/


Additional info:

Comment 2 Hu Zhang 2015-03-10 10:01:32 UTC
Verified with the package version:
libguestfs-1.20.11-14.el6.x86_64

Setup the env:
1. Make sure you have installed libguestfs packages on your test machine
2. Make sure you have installed xfsprogs on the host.
3. Make sure there is an applance in the folder /var/.guestfs-0/, includes initrd, root and kernel.
4. Add /sbin/mkfs.xfs to the /var/.guestfs-0/root.
# guestfish --rw -a /var/tmp/.guestfs-0/root
   ><fs> copy-in /sbin/mkfs.xfs /sbin

Verify steps:
1. # guestfish -N fs:xfs
2. Make a dir in the image.
    ><fs> mount /dev/sda1 /
    ><fs> mkdir /test
3. Input the following command and enter a <tab>
   ><fs> ls /test
   ><fs> ls /test/

Comment 5 errata-xmlrpc 2015-07-22 05:55:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1444.html


Note You need to log in before you can comment on or make changes to this bug.