Bug 115386 - bind : zone file not found
bind : zone file not found
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-11 15:19 EST by Jean-Francois DUMONT
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 18:26:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jean-Francois DUMONT 2004-02-11 15:19:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.4.1)
Gecko/20031114

Description of problem:
this a part of my system log when i start Bind.

Feb 11 17:52:55 slin named[32041]: starting BIND 9.2.2-P3 -u named -t
/var/named/chroot
Feb 11 17:52:55 slin named[32041]: using 1 CPU
Feb 11 17:52:55 slin named[32041]: loading configuration from
'/etc/named.conf'
Feb 11 17:52:55 slin named: D�marrage de named succeeded
Feb 11 17:52:55 slin named[32041]: no IPv6 interfaces found
Feb 11 17:52:55 slin named[32041]: listening on IPv4 interface lo,
127.0.0.1#53
Feb 11 17:52:55 slin named[32041]: listening on IPv4 interface eth0,
192.168.0.254#53
Feb 11 17:52:55 slin named[32041]: listening on IPv4 interface eth1,
192.168.60.30#53
Feb 11 17:52:55 slin named[32041]: listening on IPv4 interface ppp0,
81.56.187.6#53
Feb 11 17:52:55 slin named[32041]: command channel listening on
127.0.0.1#953
Feb 11 17:52:55 slin named[32041]: zone 0.0.127.in-addr.arpa/IN:
loading master file 0.0.127.in-addr.arpa.zone: file not found
Feb 11 17:52:55 slin named[32041]: zone 0.168.192.in-addr.arpa/IN:
loading master file 0.168.192.in-addr.arpa.zone: file not found
Feb 11 17:52:55 slin named[32041]: zone sid.local/IN: loading master
file sid.local.zone: file not found
Feb 11 17:52:55 slin named[32041]: zone localhost/IN: loading master
file localhost.zone: file not found
Feb 11 17:52:55 slin named[32041]: running



Version-Release number of selected component (if applicable):
bind-9.2.2.P3-9, ypbind-1.12-3, bind-utils-9.2.2.P3-9,
bind-devel-9.2.2.P3-9, bind-chroot-9.2.2.P3-9, redhat-config-bind-2.0.0-18

How reproducible:
Always

Steps to Reproduce:
I try to configure a DNS for a lan with this PC as gateway.
I try whith bind non-chrooted, I try to configure manualy, or with
redhat-config-bind 
    

Actual Results:  but I never succed in starting bind. 

Expected Results:  I read a lot how-to and forum, some people have the
same probleme like my problem. I'm not specialist in Bind DNS.


Additional info:


What sort of mistake do I?

Thank you

Jean-Francois DUMONT
France
Comment 1 Bart Martens 2004-02-12 00:43:47 EST
Do you have both bind and caching-nameserver installed? Does the file
/etc/named.conf have a section called "options", and in that section
an option called "directory" with value "/var/named"? Are the missing
files in /var/named ?

I may be mistaken, but at first sight, this seems to be a support
question, not a bug. Have you already tried the fedora-list?
http://www.redhat.com/mailman/listinfo/fedora-list
Comment 2 Daniel Walsh 2004-04-05 22:34:54 EDT
Please try system-config-bind off of rawhide.

Comment 3 Nicolas M. Lopez 2004-05-11 08:44:04 EDT
I've got same configuration but x86_64 and same problem.
In /var/named/chroot/etc/named.conf I added: 
include	 "/etc/named.custom";

and it works.

I also have to edit every file by hand since redhat-config-bind
removes the: include "/etc/named.custom"; every time it saves files
and it also makes weird zone files (they zone files dont make sense:
where $ORIGIN shold be I find SOA).

Then I updated to system-config-bind, a little improvement but it
still makes weird zone files that I have to edit by hand.

I've read bind 9.2.3 works fine but I have to upgrade lots of
dependencies.

Nicolas. 
Comment 4 Jason Vas Dias 2004-08-30 18:26:01 EDT
fixed in bind-9.2.4rc7-10, bind-chroot-9.2.4rc7-10,
caching-nameserver-7.3-3

Note You need to log in before you can comment on or make changes to this bug.