Bug 115395 - rsh doesn't work from Unix to Linux and from Linux to Linux
rsh doesn't work from Unix to Linux and from Linux to Linux
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: rsh (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-11 16:44 EST by Sunil Talreja
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-08 06:20:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sunil Talreja 2004-02-11 16:44:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET 
CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
on Linux box (linux1) did the following things.

1. Verified rsh service is on.
2. created .rhosts file in /home/testuser. contents of file are as 
follows:
+ testusr
3. Created entry in /etc/hosts for another linux box and unix host.

On Unix box or another Linux box I am loged in as testuser and I type

rsh linux1 date
Get the error message: permission denied.

I opened up ticket with Redhat Tech support and they were able to 
reproduce the same error and din't have the solution.

Version-Release number of selected component (if applicable):
rsh-0.17-5 & rsh-server-0.17-5.  Kernal 2.4.9-e.27smp

How reproducible:
Always

Steps to Reproduce:
1.Make sure rsh service is running on linux box
2.create .rhosts entry on above linux box
3.create entry in /etc/hosts file on above linux box
4.Go to different box and login as same user as above linux box
5. type rsh linux1(name of above linux box) date.
6. You will get error permission denied.

    

Actual Results:  Permission denied

Expected Results:  current date and time

Additional info:
Comment 1 Phil Knirsch 2004-02-13 10:34:15 EST
There is an errata pending for rsh for AS2.1, although i am not sure
if it fixes your problem.

Preliminary binaries can be downloaded here:

http://people.redhat.com/pknirsch/

These packages have not gone through QA yet, but have been tested by
myself on a local box and worked fine.

If you want to you can give them a shot and let me know if they fix
your problem.

Thanks,

Read ya, Phil
Comment 2 Karel Zak 2005-09-08 06:20:25 EDT
No response. NEEDINFO -> CANTFIX

Note You need to log in before you can comment on or make changes to this bug.