Bug 1153974 - guestfish prints '\n' in error message
Summary: guestfish prints '\n' in error message
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libguestfs
Version: 6.6
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Pino Toscano
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 923355
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-17 08:29 UTC by Lingfei Kong
Modified: 2015-07-22 05:56 UTC (History)
7 users (show)

Fixed In Version: libguestfs-1.20.11-12.el6
Doc Type: Enhancement
Doc Text:
Minor fixes and improvements have been done to the help message of the "set-append" command, an error message of the "guestfish umount" command, and to the guestfish(1) and virt-edit(1) man pages.
Clone Of:
Environment:
Last Closed: 2015-07-22 05:56:09 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1444 normal SHIPPED_LIVE libguestfs bug fix and enhancement update 2015-07-20 18:44:02 UTC

Description Lingfei Kong 2014-10-17 08:29:07 UTC
Description of problem:
guestfish do not escape the'\n' in the error message


Version-Release number of selected component (if applicable):
libguestfs-tools-c-1.20.11-11.el6.x86_64


How reproducible:
100%


Steps to Reproduce:
#guestfish umount /
libguestfs: error: umount: call launch before using this function\n(in guestfish, don't forget to use the 'run' command)


Actual results:
guestfish do not escape the'\n' in the error message


Expected results:
#guestfish umount /
libguestfs: error: umount: call launch before using this function
(in guestfish, don't forget to use the 'run' command)


Additional info:

Comment 1 Pino Toscano 2014-10-17 08:38:00 UTC
(In reply to Lingfei Kong from comment #0)
> Description of problem:
> guestfish do not escape the'\n' in the error message

No, it has nothing to do with escaping, it is just a typo in the error message; see bug #923355 which was the upstream version of this.

Comment 3 Chao Zhang 2014-12-11 01:49:16 UTC
Verify with libguestfs-tools-c-1.20.11-12.el6.x86_64

Steps to verify:

#guestfish umount /
libguestfs: error: umount: call launch before using this function
(in guestfish, don't forget to use the 'run' command)

Comment 6 errata-xmlrpc 2015-07-22 05:56:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1444.html


Note You need to log in before you can comment on or make changes to this bug.