Bug 115400 - kernel barfs when loading cisco_ipsec
kernel barfs when loading cisco_ipsec
Status: CLOSED DUPLICATE of bug 78616
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-11 17:28 EST by Kaj J. Niemi
Modified: 2007-04-18 13:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaj J. Niemi 2004-02-11 17:28:11 EST
Description of problem:
While the problem most likely is over in the cisco_ipsec camp I'm
filing this bug as a reference if someone else happens to have the
same problem.

The Cisco VPN Client 4.0.3 (B) used to work on 2.6 kernels, although
not officially supported by TAC. Unfortunately something changed
around 2.6.2-rc1 which led to breakage of the VPN Client.

Below is what happens when cisco_ipsec gets insmodded.

kernel: request_module: failed /sbin/modprobe -- cipsec0. error = 256
kernel: cisco_ipsec: no version for "struct_module" found: kernel tainted.
kernel: cisco_ipsec: no version magic, tainting kernel.
kernel: cisco_ipsec: module license 'Proprietary' taints kernel.
kernel: Unable to handle kernel paging request at virtual address 24510000
kernel:  printing eip:
kernel: c0261a6a
kernel: *pde = 00000000
kernel: Oops: 0000 [#1]
kernel: CPU:    0
kernel: EIP:    0060:[<c0261a6a>]    Tainted: PF
kernel: EFLAGS: 00010246
kernel: EIP is at register_netdev+0x1a/0x80
kernel: eax: 00002525   ebx: 24510000   ecx: c03a71e0   edx: 00000077
kernel: esi: 24510000   edi: fcfd3dc4   ebp: d5723f8c   esp: d5723f58
kernel: ds: 007b   es: 007b   ss: 0068
kernel: Process insmod (pid: 8251, threadinfo=d5722000 task=d60a08a0)
kernel: Stack: c0361a60 fcfcedc4 fcf84736 fcfa6200 d5723f80 d5723f8c
fcf84729 09b8f008
kernel:        00000000 c0351b14 fcfceda0 fcfd3b80 c0361a20 c0361a20
c0147bcc f7fb6854
kernel:        c0176cb8 e0b4b474 00000000 e0306804 d5722000 c017515f
b7fc6008 00000000
kernel: Call Trace:
kernel:  [<fcf84736>] init_module+0x5e/0x84 [cisco_ipsec]
kernel:  [<fcf84729>] init_module+0x51/0x84 [cisco_ipsec]
kernel:  [<c0147bcc>] sys_init_module+0x1ac/0x320
kernel:  [<c0176cb8>] __fput+0x98/0xf0
kernel:  [<c017515f>] filp_close+0x4f/0x80
kernel:  [<c010c49f>] syscall_call+0x7/0xb
kernel:
kernel: Code: ac 38 e0 74 09 84 c0 75 f7 be 01 00 00 00 89 f0 48 85 c0 74
kernel:  <7>request_module: failed /sbin/modprobe -- cipsec0. error = 256


Version-Release number of selected component (if applicable):
kernel-2.6.1-1.65, Cisco VPN Client 4.0.3 (B)

How reproducible:
Always

Steps to Reproduce:
1. /etc/init.d/ciscovpn start
2. 
3.
    

Actual Results:  Fails

Expected Results:  Work

Additional info:

More information:

Report report in 2.6.2-rc1:
<http://www.google.com/url?sa=U&start=1&q=http://seclists.org/lists/linux-kernel/2004/Jan/5503.html&e=7417>

Report broken in 2.6.1-mm5:
<http://groups.google.com/groups?q=cisco+vpn+linux+kernel+2.6&hl=en&lr=&ie=UTF-8&oe=utf-8&as_qdr=m3&selm=fa.kgn59gr.15lsg97%40ifi.uio.no&rnum=6>

I guess this is is not CSCeb00549 as it was fixed for 4.0.1 (A).

That said, if someone with a @cisco.com address wants a srpm which can
be built against any kernel (2.4, 2.6) reliably and reproduceably,
just let me know... The ./vpn_install isn't nice at all. O:-) It
should work on RH73/8/9/FC1/FC2/RHEL3.
Comment 1 Arjan van de Ven 2004-02-11 17:31:53 EST
this is a binary only module.

*** This bug has been marked as a duplicate of 78616 ***
Comment 2 Kaj J. Niemi 2004-02-11 17:38:45 EST
Uh, part of it (the VPN logic in libdriver.so) is binary only but you
do compile it against one particular kernel.

(paste from the installer)

INCLUDES="${INCLUDES} -I${KSRCDIR}/include/asm-i386/mach-default"
CFLAGS="${CFLAGS} -fno-common -DKBUILD_BASENAME=cisco_ipsec
-DKBUILD_MODNAME=cisco_ipsec"

$CC $CFLAGS $INCLUDES -c linuxcniapi.c
$CC $CFLAGS $INCLUDES -c interceptor.c
$CC $CFLAGS $INCLUDES -c IPSecDrvOS_linux.c
$CC $CFLAGS $INCLUDES -c frag.c
$LD -r -o cisco_ipsec frag.o linuxcniapi.o IPSecDrvOS_linux.o
interceptor.o libdriver.so

Comment 3 Arjan van de Ven 2004-02-11 18:00:17 EST
we don't support binary only kernel modules, since we cannot.
You should contact the vendor instead, they have our source we don't
have theirs.
Comment 4 Red Hat Bugzilla 2006-02-21 14:01:10 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.