Bug 1154115 - [RFE] qemu chardev socket should support TLS and auth
Summary: [RFE] qemu chardev socket should support TLS and auth
Keywords:
Status: CLOSED DUPLICATE of bug 1300773
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Amit Shah
QA Contact: Min Deng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-17 15:09 UTC by Jiri Belka
Modified: 2016-09-07 07:21 UTC (History)
13 users (show)

Fixed In Version: qemu-2.6
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-07 07:21:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Description Jiri Belka 2014-10-17 15:09:56 UTC
Description of problem:
it would be nice if qemu would support TLS for chardev sockets, so connection to VM's serial port via network would be encrypted. this should be possible for both client and server modes. spice option supports tls so code could be re-used probably.

there should be also optional possibility to define password for such connection (like for spice).

why? access to VM's serial console without ssh to host itself.
client mode could be used to "attach" consoles to central console server.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. make chardev socket to be connected via encrypted mode
2.
3.

Actual results:
not possible

Expected results:
should be possible

Additional info:

Comment 1 Jiri Belka 2014-10-17 15:11:35 UTC
i suppose this would also need libvirt part when this is accepted.

Comment 3 Amit Shah 2016-06-06 10:02:51 UTC
This support was added to QEMU 2.6 via this commit

a8fb542705ac7e0dcf00908bc47bf49cdd058abe

Information on this feature is on the upstream changelog page:

http://qemu-project.org/ChangeLog/2.6#Character_devices

Comment 5 Min Deng 2016-09-06 02:01:08 UTC
Hi Amit,
   Could you please provide QE some use cases about this bug in order to verify this bug ? Thanks in advance.
Best Regards,
Min

Comment 6 Amit Shah 2016-09-07 07:21:51 UTC
I'll just mark this bug a dup of 1300773 since it has more info, and test cases.

*** This bug has been marked as a duplicate of bug 1300773 ***


Note You need to log in before you can comment on or make changes to this bug.