Bug 115423 - hangul LE crashes gimlet and doesn't work with httx
Summary: hangul LE crashes gimlet and doesn't work with httx
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: im-sdk   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Yu Shao
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-02-12 09:01 UTC by Jens Petersen
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: 11.4-26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-16 14:18:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
use ko_KR instead of ko to name hangul LE (500 bytes, patch)
2004-02-18 08:44 UTC, Jens Petersen
no flags Details | Diff

Description Jens Petersen 2004-02-12 09:01:46 UTC
Description of problem:
Start a Korean gnome session and it is not possible to add gimlet
to the gnome panel - if there is one already there it crashes.
Hangul LE doesn't work with httx bridge either.  Something seems
to be wrong with iiimf-le-hangul.

Version-Release number of selected component (if applicable):
11.4-9

How reproducible:
every time

Additional info:
This was working very recently.

Comment 1 Jens Petersen 2004-02-12 09:03:05 UTC
Further note - it doesn't seem possible to switch to Hangul IM
when running gimlet in another locale either.

Comment 2 Yu Shao 2004-02-17 17:30:27 UTC
Could someone have a look of it with im-sdk-11.4-11? Thanks.

Comment 3 Lawrence Lim 2004-02-18 03:23:06 UTC
I had a go with im-sdk-11.4-11. I started gimlet with Canna LE, 
switched to Hangul LE, typed something and switched back to Canna LE 
again. No crash. Good work Yu Shao. 

Comment 4 Jens Petersen 2004-02-18 05:39:10 UTC
It still doesn't actually switch to hangul for me.

See openi18n-im:00668.


Comment 5 Jens Petersen 2004-02-18 08:44:17 UTC
Created attachment 97783 [details]
use ko_KR instead of ko to name hangul LE

This seems to fix the problem.

Comment 6 Jens Petersen 2004-02-19 07:31:30 UTC
Thanks.

Comment 7 Jens Petersen 2004-03-11 07:36:25 UTC
This is happening with 11.4-25 again.

Perhaps gimlet-korean-name-115423.patch is no longer needed?

Comment 8 Lawrence Lim 2004-03-11 23:53:28 UTC
You could be right jens, is it possible to have the patch remove in
the next version -26?

Latest Changelog for hangul LE (2004-02-29):
* leif.c: rename locale name to "han geug eo", and add "ko" to the
supported locale
* composer.h, composer.c: upgrade candidate(hanja) routine
* tables/candidate.txt: add new candidate dictionary file

Comment 9 Yu Shao 2004-03-12 21:43:43 UTC
Took gimlet-korean-name-115423.patch out and rebuilt as 11.4-26.

Comment 10 Jens Petersen 2004-03-16 14:18:57 UTC
Thanks, seems to be fine again.


Note You need to log in before you can comment on or make changes to this bug.