Bug 1154284 - [/usr/lib/systemd/system/cups.service:12] Unknown lvalue 'After' in section 'Install'
Summary: [/usr/lib/systemd/system/cups.service:12] Unknown lvalue 'After' in section '...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1154322 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-18 10:51 UTC by Heldwin
Modified: 2014-11-10 05:55 UTC (History)
3 users (show)

Fixed In Version: cups-1.7.5-13.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-29 11:05:03 UTC
Type: Bug


Attachments (Terms of Use)

Description Heldwin 2014-10-18 10:51:20 UTC
Description of problem:
There an 'After' lvalue in the [Install] section in the file: /usr/lib/systemd/system/cups, that, I believe, should be in [Unit].

After=network.target

Version-Release number of selected component (if applicable):
cups-1.7.5-10.fc21.x86_64

How reproducible:
Always

Steps to Reproduce:
1. update cups to version 1.7.5-10
2. cat /var

Actual result:

There is a log in /var/log/messages:
systemd: [/usr/lib/systemd/system/cups.service:12] Unknown lvalue 'After' in section 'Install'

File /usr/lib/systemd/system/cups.service :

--------------------
[Unit]
Description=CUPS Printing Service

[Service]
Type=notify
ExecStart=/usr/sbin/cupsd -f
PrivateTmp=true

[Install]
Also=cups.socket cups.path
WantedBy=printer.target
After=network.target
--------------------

Correct me if I am wrong, but I belive it should be:

--------------------
[Unit]
Description=CUPS Printing Service
After=network.target

[Service]
Type=notify
ExecStart=/usr/sbin/cupsd -f
PrivateTmp=true

[Install]
Also=cups.socket cups.path
WantedBy=printer.target
--------------------

Comment 1 Heldwin 2014-10-18 10:53:46 UTC
sorry,

1. update cups to version 1.7.5-10
2. cat /usr/lib/systemd/system/cups.service

Comment 2 Tim Waugh 2014-10-18 15:09:31 UTC
Thanks! Should be fixed in the latest build.

Comment 3 Fedora Update System 2014-10-18 15:25:51 UTC
cups-1.7.5-11.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/FEDORA-2014-13104/cups-1.7.5-11.fc21

Comment 4 Fedora Update System 2014-10-18 15:42:47 UTC
cups-1.7.5-9.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/cups-1.7.5-9.fc20

Comment 5 Fedora Update System 2014-10-18 16:59:21 UTC
Package cups-1.7.5-9.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cups-1.7.5-9.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-13191/cups-1.7.5-9.fc20
then log in and leave karma (feedback).

Comment 6 Heldwin 2014-10-18 17:17:07 UTC
Thanks, fixed it

Comment 7 Tim Waugh 2014-10-18 20:13:56 UTC
*** Bug 1154322 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2014-10-29 11:05:03 UTC
cups-1.7.5-11.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2014-11-10 05:55:08 UTC
cups-1.7.5-13.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.