Bug 1154364 - [RHEV 3.5 Beta] cannot create snapshot of VM.
Summary: [RHEV 3.5 Beta] cannot create snapshot of VM.
Keywords:
Status: CLOSED DUPLICATE of bug 1149460
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Nobody
QA Contact:
URL:
Whiteboard: virt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-19 09:50 UTC by Ulhas Surse
Modified: 2014-11-12 11:44 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-12 11:44:03 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Ulhas Surse 2014-10-19 09:50:53 UTC
Description of problem:
Cannot create snapshot of running VM. 

Version-Release number of selected component (if applicable):
rhevm-3.5.0-0.12.beta

How reproducible:
Always

Steps to Reproduce:
1. Try to create snopshot of VM.
2. It will fail with "Cannot create Snapshot. Opetration not supported by QEMU.
3.

Actual results:
"Cannot create Snapshot. Opetration not supported by QEMU.

Expected results:
Snapshot should be created without error.

Additional info:

Comment 1 Omer Frenkel 2014-10-20 06:30:42 UTC
this happens when qemu on the host does not support this feature,
i assume you need to upgrade libvirt/qemu
what versions of vdsm/libvirt/qemu running on your host?

Comment 2 Omer Frenkel 2014-10-20 07:47:45 UTC
might be duplicate of bug 1149460
which is result of libvirt bug 1149667

Comment 5 Francesco Romani 2014-11-10 09:15:11 UTC
Hi,

This bug may be also relevant:
https://bugzilla.redhat.com/show_bug.cgi?id=1159211

First thing is to check libvirt status. Please follow these instructions:

https://bugzilla.redhat.com/show_bug.cgi?id=1158469#c2

After libvirt, you may want to check wath VDSM knows.
On the affected host:

# vdsClient -s 0 getVdsCaps | grep -i livesnap

Engine will just read this value without additional logic.
Please note that VDSM is just a middleman here, so libvirt is the authoritative source.

If libvirt is behaving correctly, you may have hit bz1159211.
It is possible if you update libvirt after the affected host was added to oVirt Engine.

If so, unfortunately there is no workaround until next beta (at that point this issue will just disappear), so a manual intervention is needed:

https://bugzilla.redhat.com/show_bug.cgi?id=1149460#c32
(equivalent instructions here but with worse SNR
https://bugzilla.redhat.com/show_bug.cgi?id=1159211#c0 )

Comment 6 Omer Frenkel 2014-11-10 09:32:33 UTC
please see steps to proceed from Francesco in comment 5

Comment 7 Ulhas Surse 2014-11-11 02:26:49 UTC
Hello,

following are the outputs: 

# vdsClient -s 0 getVdsCaps | grep -i livesnap
liveSnapshot = 'false' 

#  virsh -r capabilities | grep -i snapshot
<disksnapshot default='off' toggle='no'/>
<disksnapshot default='off' toggle='no'/>

So I think we can mark this as duplicate of 1149460.

Comment 8 Omer Frenkel 2014-11-12 11:44:03 UTC

*** This bug has been marked as a duplicate of bug 1149460 ***


Note You need to log in before you can comment on or make changes to this bug.