Bug 1154375 - [RFE] rhn-migrate-classic-to-rhsm should support activation keys
Summary: [RFE] rhn-migrate-classic-to-rhsm should support activation keys
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.7
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: John Sefler
Mark Flitter
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel67
TreeView+ depends on / blocked
 
Reported: 2014-10-19 11:20 UTC by Rich Jerrido
Modified: 2015-07-22 06:52 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
subscription-manager supports activation keys for automated migration The rhn-migrate-classic-to-rhsm tool now supports activation keys when registering to Red Hat Subscription Management (RHSM). This simplifies automated migration.
Clone Of:
Environment:
Last Closed: 2015-07-22 06:52:36 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1345 normal SHIPPED_LIVE subscription-manager and python-rhsm bug fix and enhancement update 2015-07-20 17:59:53 UTC

Description Rich Jerrido 2014-10-19 11:20:26 UTC
Description of problem:
The rhn-migrate-classic-to-rhsm script can be used to migrate an existing user of a 'Classic' product (RHN Classic and/or Satellite 5.x) to a certificate based platform (RHSM, SAM, Satellite 6). 

Activation keys are frequently used in automation scripts so that users do not have to embed user/name passwords in scripts. Both SAM & Satellite 6 currently support activation keys for this purpose. 

This RFE requests the addition of activation key support to rhn-migrate-classic-to-rhsm to support this. (The underlying subscription-manager tooling supports this)


Version-Release number of selected component (if applicable):
subscription-manager-migration-1.12.14-7.el6.x86_64

How reproducible:
100%

Comment 2 Bryan Kearney 2014-11-03 19:55:05 UTC
Moving bugs to 6.7

Comment 4 Alex Wood 2015-04-06 13:14:38 UTC
commit 00461f3751f9db182227c9973c41b305e378638a
Author: Alex Wood <awood@redhat.com>
Date:   Thu Feb 19 19:56:06 2015 +0000

    1154375: Allow use of activation keys during migration.

Comment 6 Shwetha Kallesh 2015-04-14 10:27:09 UTC
Marking verified!!

[root@dhcp35-135 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.47-1
subscription management rules: 5.14
subscription-manager: 1.14.3-1.el6
python-rhsm: 1.14.2-1.el6

[root@dhcp35-135 ~]# rhn-migrate-classic-to-rhsm --activation-key rhn_key --org admin
Legacy username: qa@redhat.com
Legacy password: 

Retrieving existing legacy subscription information...

+-----------------------------------------------------+
System is currently subscribed to these legacy channels:
+-----------------------------------------------------+
rhel-x86_64-client-6

+-----------------------------------------------------+
Installing product certificates for these legacy channels:
+-----------------------------------------------------+
rhel-x86_64-client-6

Product certificates installed successfully to /etc/pki/product.

Preparing to unregister system from legacy server...
System successfully unregistered from legacy server.

Attempting to register system to destination server...
The system has been registered with ID: a85d58e8-126f-409c-930d-ef9578af3c60 

Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Desktop
Status:       Not Subscribed

Product Name: Awesome OS Instance Server Bits
Status:       Subscribed

Comment 7 errata-xmlrpc 2015-07-22 06:52:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1345.html


Note You need to log in before you can comment on or make changes to this bug.