Bug 1154420 - ParaNdis6_SendNetBufferList should dispatch each net buffer to a separate queue
Summary: ParaNdis6_SendNetBufferList should dispatch each net buffer to a separate queue
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.2
Hardware: Unspecified
OS: Windows
unspecified
medium
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-19 14:59 UTC by Yossi Hindin
Modified: 2015-11-24 08:44 UTC (History)
8 users (show)

Fixed In Version: virtio-win-prewhql-0.1-99
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2015-11-24 08:44:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2513 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-11-24 13:38:38 UTC

Description Yossi Hindin 2014-10-19 14:59:39 UTC
The coding issue was discovered during the preview: there is no guaranty that all NET_BUFFER's instance in the NET_BUFFER_LIST have the same RSS hash value, so the list has to be split into separate entries and the entries dispatched independently.
The issue has no known external manifestation

Comment 2 Min Deng 2014-10-21 03:03:15 UTC
Hi Yossi,
   Can you help to tell QE how to reproduce the bug on QE side ? Thanks
Thanks
Min

Comment 4 Yossi Hindin 2015-01-12 08:21:03 UTC
The issue covers the code refactoring, no special testing is required other than general regression check.

Comment 8 lijin 2015-07-17 07:18:25 UTC
all netkvm whql job passed with build 105.

So change status to verified

Comment 10 errata-xmlrpc 2015-11-24 08:44:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html


Note You need to log in before you can comment on or make changes to this bug.