Bug 1154669 - Hosts get disassociated from deployment after editing
Summary: Hosts get disassociated from deployment after editing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: ruby193-rubygem-staypuft
Version: 5.0 (RHEL 6)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: z2
: Installer
Assignee: Brad P. Crochet
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-20 13:25 UTC by Imre Farkas
Modified: 2016-09-20 05:03 UTC (History)
9 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.4.7-1.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-04 17:03:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Imre Farkas 2014-10-20 13:25:55 UTC
Description of problem:
Hosts get disassociated from deployment after editing. The hostgroup combobox defaults to blank on the edit page, instead of the actual hostgroup of the host which is displayed correctly on the show page

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. create deployment
2. assign a host
3. go to edit, then submit the form

Actual results:
the host got disassociated

Expected results:
the hostgroup should remain untouched

Additional info:

Comment 1 Brad P. Crochet 2014-10-20 16:56:50 UTC
PR available: https://github.com/theforeman/staypuft/pull/354

Comment 2 Jason E. Rist 2014-10-20 22:04:22 UTC
Merged

Comment 7 Alexander Chuzhoy 2014-10-21 15:12:47 UTC
Verified:
openstack-puppet-modules-2014.1-24.el6ost.noarch
rhel-osp-installer-0.4.5-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-foreman-installer-2.0.30-1.el6ost.noarch
ruby193-rubygem-staypuft-0.4.7-1.el6ost.noarch


The reported issue doesn't reproduce now.

Comment 9 Mike Burns 2014-10-24 14:53:43 UTC
This was an internal issue that was never customer visible.  no doc text needed.

Comment 11 errata-xmlrpc 2014-11-04 17:03:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.