Bug 115467 - Can't add to addressbook
Can't add to addressbook
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-12 14:31 EST by Brian Fahrlander
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-31 16:15:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Fahrlander 2004-02-12 14:31:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040124 Galeon/1.3.12

Description of problem:
When an email comes in and I attempt to add the address to my book, I
get a small window that says "(addressee/email address) Querying
Addressbook" and it hangs there.

I DO HAVE an LDAP server that I created from the LinuxJournal howto,
and it may be flawed.  Even so, it should time out in just a couple of
moments, and not just sit there.

This is probably as much my problem as it is Evolution, but not being
able to add new people is kind of a serious problem. 

If you'll email me directly, I'll give you access to this machine and
the LDAP server in question, so you can see the problem in it's native
environment.

Version-Release number of selected component (if applicable):
evolution-1.5.3-1

How reproducible:
Always

Steps to Reproduce:
1.Right click on the address of an existing email.
2.Select "Add to addressbook"
3.Window comes up, and waits. (Forever?)
    

Actual Results:  The window stays, apparently until you kill it, or
lightning strikes.  :>

Expected Results:  I would have expected it to open a small window
that would also ask for other things for this person, like it usually
does...but we don't get there.


Additional info:
Comment 1 Brian Fahrlander 2004-02-20 01:20:27 EST
Update:  after upgrading to evolution-1.5.4-1 I'm able to create a NEW
contact, but still unable to take the information directly from an
email message.  That helps a lot.

And what happened to Tools->Settings->Directory-settings? Maybe it's
moved into another area, but the only sign that I even have an LDAP
server to query (AutoCompletion) doesn't allow me to change it.

Comment 2 Dave Malcolm 2004-09-01 17:22:13 EDT
Thanks for the report, sorry I haven't had a chance to reply for so
long.  Have you tried this with more recent versions of Evolution?
(1.5.93 is the latest in Rawhide)
Comment 3 Brian Fahrlander 2004-09-06 20:49:29 EDT
Actually, that was one of the last things I did before deciding that
the bleeding edge wasn't someplace I wanted to be. :(  These days I'm
now running whatever the 'stable' version is, from the regular repos,
not the rawhide/testing/etc repos, sorry.

But maybe this would be a good place for a question: I want to make an
LDAP server intended to be used with Evolution- could I just use the
usual 'templates', or do I have to do something to ensure compatabilty?

(This is no place for a reply- just mark this as a dead issue and let
me know off-line.  If it's still a problem, we'll go into detail and
cover it completely.)

Thanks! 
Comment 4 Dave Malcolm 2004-09-07 13:54:43 EDT
Well, if it's an Evolution problem, it probably ought to be fixed!

BTW, the Tools->Settings->Directory Settings GUI was in Evo 1.4; in
1.5 it is  accessible by right-clicking on the specific addressbook
and selecting "Properties".

Problems with editing sound like either a permissions problem, or a
schema problem.  Check the Properties to see what authentication
method you're using.  For schemas, the evolution-data-server package
contains a file 
/usr/share/evolution-data-server-1.0/evolutionperson.schema
It would be useful if you could try adding this to your server and see
if things work better.
Comment 5 Brian Fahrlander 2004-12-24 07:14:08 EST
This is now a non-problem; I created an LDAP from memory and got
authentication going, so I'm back in the clear for the important
stuff.  With Redhat moving to the Netscape's Directory services, the
point will become moot- now we have a mature, working standard to work
towards.  There won't be the desire to have the "Evolution" or the
"Outlook" standards- just the Netscape (now Redhat) standard and all
will be well.

Let's kill this one off, and narrow the range of problems.  If it's a
problem in the future, we'll address it, then.
Comment 7 Matthew Barnes 2006-12-31 16:15:09 EST
Closing per comment #5.  Feel free to re-open this bug if you encounter the
problem again in Fedora Core 6.
Comment 8 Brian Fahrlander 2006-12-31 18:29:40 EST
Sure; put a fork in it. Because of reasons like this, as well as
business-specific, not need-specific decisions on the part of Redhat, I've gone
to Ubuntu. See the notice of legacy-closure today for another example. Choices
are now based on what Redhat's prepared to pay for, not what will keep the
project going. (See also AT&T's Unix: running a good idea into the ground in
only 10 years for business reasons.) 

I never bought the Debian "purity" argument; when I was with Redhat (from 4.0 to
FC4, I might add) it didn't seem to matter. Good luck, guys.

Note You need to log in before you can comment on or make changes to this bug.