Bug 1154745 - rubygem-staypuft: Editing a host: no network traffic type is specified in the networks' help text in the tab network.
Summary: rubygem-staypuft: Editing a host: no network traffic type is specified in th...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: z2
: Installer
Assignee: Imre Farkas
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-20 16:32 UTC by Alexander Chuzhoy
Modified: 2016-09-20 05:03 UTC (History)
6 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.4.10-1.el6ost
Doc Type: Bug Fix
Doc Text:
The API of the library used to override Foreman views have changed. The feature in Staypuft did not support both API versions. As a result, installations using the old version of the library did not display the network traffic type parameter. With this update, Staypuft handles both versions of the API and the network traffic type is displayed regardless of the version of the library.
Clone Of:
Environment:
Last Closed: 2014-11-04 17:03:41 UTC


Attachments (Terms of Use)
interface with the "external" role (52.99 KB, image/png)
2014-10-22 08:59 UTC, Imre Farkas
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Alexander Chuzhoy 2014-10-20 16:32:25 UTC
rubygem-staypuft:  Editing a host: no network traffic type is specified in the networks' help text in the tab network.

Environment:
openstack-foreman-installer-2.0.30-1.el6ost.noarch
rhel-osp-installer-0.4.5-1.el6ost.noarch
openstack-puppet-modules-2014.1-24.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch


Steps to reproduce:
1. Run rhel-osp-installer.
2. Create a deployment (create networks, assign roles).
3. Assign hosts to deployment and complete the "configure networks" form for all.
4. Select a host that was already configured, click on edit and go to the "Network" tab.

Results.
no network traffic type is specified in the networks' help text

Expected result:
network traffic type should be specified in the networks' help text

Comment 1 Imre Farkas 2014-10-21 07:32:09 UTC
PR: https://github.com/theforeman/staypuft/pull/356

Comment 3 Alexander Chuzhoy 2014-10-21 20:24:53 UTC
Verified: FailedQA

Environment:
openstack-puppet-modules-2014.1-24.el6ost.noarch
rhel-osp-installer-0.4.5-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-foreman-installer-2.0.30-1.el6ost.noarch
ruby193-rubygem-staypuft-0.4.8-1.el6ost.noarch

The traffic type is specified on all interfaces except:
1. The interface with the "external" role
2. The primary interface.

Comment 4 Imre Farkas 2014-10-22 08:59:26 UTC
Created attachment 949300 [details]
interface with the "external" role

Comment 5 Imre Farkas 2014-10-22 09:00:51 UTC
I can't reproduce the issue with the external role. It displays correctly as the atttached screenshot show. 

Could you please provide me an environment where I can reproduce it?

Comment 6 Imre Farkas 2014-10-22 11:52:26 UTC
PR for the primary interface issue: https://github.com/theforeman/staypuft/pull/359

Comment 7 Imre Farkas 2014-10-22 14:48:05 UTC
The issue with the "external" role seems to be invalid.

Comment 8 Alexander Chuzhoy 2014-10-22 14:49:13 UTC
The issue was shown - relevant only for the primary interface. The proposed patch in comment #6 should cover it.

Comment 12 Alexander Chuzhoy 2014-10-24 15:33:43 UTC
Verified:
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
rhel-osp-installer-0.4.5-2.el6ost.noarch
openstack-puppet-modules-2014.1-24.1.el6ost.noarch
openstack-foreman-installer-2.0.31-1.el6ost.noarch
ruby193-rubygem-staypuft-0.4.10-1.el6ost.noarch

The network traffic type is properly shown on NICs assigned to subnets.

Comment 14 errata-xmlrpc 2014-11-04 17:03:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.