Bug 115475 - unable to connect to some sites
unable to connect to some sites
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
http://www.royalmail.co.uk
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-12 15:32 EST by Torgeir Veimo
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-13 11:29:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Torgeir Veimo 2004-02-12 15:32:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
I am unable to connect to certain sites, eg.
http://www.royalmail.co.uk, or to download suns jdk1.5.0-beta,
http://javashoplm.sun.com/ECom/docs/Welcome.jsp?StoreId=22&PartDetailId=j2sdk-1.5.0-beta-oth-JPR&SiteId=JSC&TransactionId=noreg
(this link is on the site http://java.sun.com/j2se/1.5.0/download.jsp,
select download in the SDK column).

I have seen this on two machines on completely different networks,
where rebooting into windows with the same ip address allows the
download to be performed flawlessly.



Version-Release number of selected component (if applicable):
kernel-smp-2.6.2-1.160

How reproducible:
Always

Steps to Reproduce:
1. go to http://java.sun.com/j2se/1.5.0/download.jsp
2. select download in the SDK column
3. wait for connection timeout
    

Actual Results:  connection timeout

Expected Results:  successfull download

Additional info:
Comment 1 Torgeir Veimo 2004-02-12 16:38:51 EST
I found out that it is fixed by turning off TCP ECN, using 

echo 0 >/proc/sys/net/ipv4/tcp_ecn

Comment 2 Dave Jones 2004-02-13 11:29:01 EST
not a bug, the sites in question need to update their routers to use
RFC compliant firmware.  Alternatively, you have the workaround you
already discovered, which you can drop into /etc/sysctl.conf

Note You need to log in before you can comment on or make changes to this bug.