Bug 1154778 - RFE: Backport udev.event_timeout (kernel parameter) to RHEL 7
Summary: RFE: Backport udev.event_timeout (kernel parameter) to RHEL 7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: systemd-maint
QA Contact: Karel Volný
URL:
Whiteboard:
Depends On: 1160488
Blocks: TRACKER-bugs-affecting-libguestfs 1151033 1153589 1159804
TreeView+ depends on / blocked
 
Reported: 2014-10-20 18:07 UTC by Richard W.M. Jones
Modified: 2016-08-08 12:10 UTC (History)
7 users (show)

Fixed In Version: systemd-208-17.el7
Doc Type: Enhancement
Doc Text:
Feature: new option udev.event-timeout=<NNN> Reason: libguestfs used udevtimeout=<NNN> but it was removed. Result: udev.event-timeout=<NNN> works for them.
Clone Of:
Environment:
Last Closed: 2015-03-05 11:10:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0509 normal SHIPPED_LIVE systemd bug fix and enhancement update 2015-03-05 16:01:17 UTC

Description Richard W.M. Jones 2014-10-20 18:07:46 UTC
Description of problem:

udev used to have a udevtimeout=<NNN> kernel option.  We used this
in libguestfs to allow udev not to kill stuff randomly when accessing
very slow disks (usually remote over http/https).

We recently noticed that this option has gone.  And that a new
option udev.event-timeout=<NNN> was added upstream instead.

So the request is to backport this to RHEL 7 udev.

The main commit is:

commit 9719859c07aa13539ed2cd4b31972cd30f678543
Author: Hannes Reinecke <hare@suse.de>
Date:   Tue Jul 29 09:06:14 2014 +0200

and perhaps the one which follows it.  (Note that I only care about
the kernel cmdline option, I don't care about the udevd command line
option).

Version-Release number of selected component (if applicable):

systemd-208-11.el7.x86_64

How reproducible:

(Depends on the speed of your internet connection)

Steps to Reproduce:
1. Commands such as:

guestfish --ro -a https://download.fedoraproject.org/pub/fedora/linux/updates/20/Images/x86_64/Fedora-x86_64-20-20140407-sda.qcow2 -i

Additional info:

The most urgent need is for supporting v2v imports from VMware vCenter
which has a ridiculously slow https server.
https://bugzilla.redhat.com/show_bug.cgi?id=1151033
https://bugzilla.redhat.com/show_bug.cgi?id=1153589

Comment 2 Richard W.M. Jones 2014-10-21 07:35:32 UTC
Scratch build of systemd with event-timeout fix:

http://brewweb.devel.redhat.com/brew/taskinfo?taskID=8139893

Comment 6 Jiri Herrmann 2014-12-12 15:31:59 UTC
If this Feature should be included in the 7.1 Release Notes, could you please change the Doc Type from Enhancement to "Release Note"?

Note that the Release Notes are intended to list the most prominent and customer-relevant new features rather than every single enhancement.

Cheers,
Jirka

Comment 10 errata-xmlrpc 2015-03-05 11:10:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0509.html


Note You need to log in before you can comment on or make changes to this bug.