Bug 1154785 - rubygem-staypuft: Public_api role assignment to network - need to add validation that the network has a gateway configured.
Summary: rubygem-staypuft: Public_api role assignment to network - need to add validat...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: z2
: Installer
Assignee: Brad P. Crochet
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-20 18:34 UTC by Alexander Chuzhoy
Modified: 2014-11-04 17:03 UTC (History)
3 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.4.8-1.el6ost
Doc Type: Known Issue
Doc Text:
Cause: The subnet that contains Public-API traffic must include a gateway but the wizard does not enforce this. Consequence: The user can create a subnet that does not define a gateway leading to a broken network setup. Workaround (if any): Define a Gateway on the subnet containing public-api network traffic Result: the network configuration works.
Clone Of:
Environment:
Last Closed: 2014-11-04 17:03:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Alexander Chuzhoy 2014-10-20 18:34:46 UTC
rubygem-staypuft: Public_api role assignment to network - need to add validation that the network has a gateway configured.

Environment:
openstack-foreman-installer-2.0.30-1.el6ost.noarch
ruby193-rubygem-staypuft-0.4.6-1.el6ost.noarch
rhel-osp-installer-0.4.5-1.el6ost.noarch
openstack-puppet-modules-2014.1-24.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch


Steps to reproduce:
1. Install rhel-osp-installer.
2. Create a deployment.
3. Create a subnet using "No existing DHCP" and don't specify GW on it.
4. Assign the Public Api role to this subnet.
5. Continue with the deployment normally.

Results:
Since the gateway is configured for the network where the public api role is assigned - this causes the installed host to have no default gateway.

Expected results:

The public_api role assignment to the network should be declined if the network doesn't have a gateway.

Comment 1 Alexander Chuzhoy 2014-10-20 18:37:28 UTC
Checking the respective ifcfg file:
GATEWAY=""
DEFROUTE=yes

Comment 3 Arthur Berezin 2014-10-21 14:00:19 UTC
Can we make the effort and add the UI validation for A2. this is critical to stand up an operational network layout.

Comment 4 Mike Burns 2014-10-21 16:05:02 UTC
https://github.com/theforeman/staypuft/pull/358

Comment 6 Alexander Chuzhoy 2014-10-21 18:46:37 UTC
Verified:
openstack-puppet-modules-2014.1-24.el6ost.noarch
rhel-osp-installer-0.4.5-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-foreman-installer-2.0.30-1.el6ost.noarch
ruby193-rubygem-staypuft-0.4.8-1.el6ost.noarch



There's a validation now that the network where the public_api role is assigned has a gateway.

Comment 9 errata-xmlrpc 2014-11-04 17:03:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.