Bug 1154884 - qt5-qtbase-gui requires gtk2
Summary: qt5-qtbase-gui requires gtk2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qt5-qtbase
Version: 21
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: depchain
TreeView+ depends on / blocked
 
Reported: 2014-10-20 23:26 UTC by Kevin Kofler
Modified: 2014-11-07 02:38 UTC (History)
7 users (show)

Fixed In Version: qt5-qtbase-5.3.2-4.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-01 16:59:49 UTC


Attachments (Terms of Use)

Description Kevin Kofler 2014-10-20 23:26:48 UTC
Description of problem:
qt5-qtbase-gui includes %{_libdir}/usr/lib/qt5/plugins/platformthemes/libqgtk2.so, which requires sonames from gtk2.

Version-Release number of selected component (if applicable):
qt5-qtbase-gui-5.3.2

How reproducible:
Always

Steps to Reproduce:
1. Try to uninstall gtk2.

Actual results:
It wants to remove qt5-qtbase-gui and everything that depends on it.

Expected results:
Qt should not depend on GTK+.

Additional info:
Please move the offending platform theme into a subpackage.

Note that the widget style actually loads GTK+ dynamically, only the platform theme (which integrates GTK+ dialogs) has it linked.

Comment 1 Kevin Kofler 2014-10-20 23:34:39 UTC
PS: I'd propose a qt5-qtbase-gui-platformtheme-gtk2 subpackage. If you agree with that, I can work on it myself. I just don't want to do this without discussion.

Comment 2 Kevin Kofler 2014-10-21 00:58:34 UTC
As discussed with Rex Dieter on IRC, it looks like we can just filter the Requires. Qt does not complain if it fails to load a platform theme, so we can just let it fail if gtk2 is not installed (and either use a different plugin such as the KDE one or fall back to the builtin dialogs, which it would also do if the platform theme was in a subpackage).

Comment 3 Kevin Kofler 2014-10-23 00:54:22 UTC
I fixed this now in Rawhide (and confirmed that the filtering is working), but I'm keeping the bug open until at least F21 is also fixed.

Comment 4 Fedora Update System 2014-10-25 16:08:38 UTC
qt5-qtbase-5.3.2-4.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/qt5-qtbase-5.3.2-4.fc21

Comment 5 Fedora Update System 2014-10-25 16:11:30 UTC
qt5-qtbase-5.3.2-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/qt5-qtbase-5.3.2-4.fc20

Comment 6 Fedora Update System 2014-10-25 16:17:31 UTC
qt5-qtbase-5.3.2-4.fc19,qt5-qtconnectivity-5.3.2-1.fc19,qt5-qtdeclarative-5.3.2-1.fc19,qt5-qtdoc-5.3.2-1.fc19,qt5-qtgraphicaleffects-5.3.2-1.fc19,qt5-qtimageformats-5.3.2-1.fc19,qt5-qtlocation-5.3.2-1.fc19,qt5-qtmultimedia-5.3.2-1.fc19,qt5-qtquick1-5.3.2-1.fc19,qt5-qtquickcontrols-5.3.2-1.fc19,qt5-qtscript-5.3.2-1.fc19,qt5-qtsensors-5.3.2-1.fc19,qt5-qtserialport-5.3.2-1.fc19,qt5-qtsvg-5.3.2-1.fc19,qt5-qttools-5.3.2-1.fc19,qt5-qttranslations-5.3.2-1.fc19,qt5-qtwebkit-5.3.2-1.fc19,qt5-qtx11extras-5.3.2-1.fc19,qt5-qtxmlpatterns-5.3.2-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/qt5-qtbase-5.3.2-4.fc19,qt5-qtconnectivity-5.3.2-1.fc19,qt5-qtdeclarative-5.3.2-1.fc19,qt5-qtdoc-5.3.2-1.fc19,qt5-qtgraphicaleffects-5.3.2-1.fc19,qt5-qtimageformats-5.3.2-1.fc19,qt5-qtlocation-5.3.2-1.fc19,qt5-qtmultimedia-5.3.2-1.fc19,qt5-qtquick1-5.3.2-1.fc19,qt5-qtquickcontrols-5.3.2-1.fc19,qt5-qtscript-5.3.2-1.fc19,qt5-qtsensors-5.3.2-1.fc19,qt5-qtserialport-5.3.2-1.fc19,qt5-qtsvg-5.3.2-1.fc19,qt5-qttools-5.3.2-1.fc19,qt5-qttranslations-5.3.2-1.fc19,qt5-qtwebkit-5.3.2-1.fc19,qt5-qtx11extras-5.3.2-1.fc19,qt5-qtxmlpatterns-5.3.2-1.fc19

Comment 7 Fedora Update System 2014-10-27 08:17:58 UTC
Package qt5-qtbase-5.3.2-4.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qt5-qtbase-5.3.2-4.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-13646/qt5-qtbase-5.3.2-4.fc21
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2014-11-01 16:59:49 UTC
qt5-qtbase-5.3.2-4.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Jaroslav Reznik 2014-11-03 09:59:31 UTC
(In reply to Kevin Kofler from comment #2)
> As discussed with Rex Dieter on IRC, it looks like we can just filter the
> Requires. Qt does not complain if it fails to load a platform theme, so we
> can just let it fail if gtk2 is not installed (and either use a different
> plugin such as the KDE one or fall back to the builtin dialogs, which it
> would also do if the platform theme was in a subpackage).

Personally I'd prefer subpackage, to make sure all requirements are available on system instead of silently failing.

Comment 10 Kevin Kofler 2014-11-03 10:17:39 UTC
Well, the point of the platform theme plugin is integrating into GTK+ desktops, which should have GTK+ installed to begin with. Nobody needs the GTK+ platform theme on a Qt desktop environment.

Comment 11 Fedora Update System 2014-11-07 02:32:33 UTC
qt5-qtbase-5.3.2-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2014-11-07 02:38:31 UTC
qt5-qtbase-5.3.2-4.fc19, qt5-qtconnectivity-5.3.2-1.fc19, qt5-qtdeclarative-5.3.2-1.fc19, qt5-qtdoc-5.3.2-1.fc19, qt5-qtgraphicaleffects-5.3.2-1.fc19, qt5-qtimageformats-5.3.2-1.fc19, qt5-qtlocation-5.3.2-1.fc19, qt5-qtmultimedia-5.3.2-1.fc19, qt5-qtquick1-5.3.2-1.fc19, qt5-qtquickcontrols-5.3.2-1.fc19, qt5-qtscript-5.3.2-1.fc19, qt5-qtsensors-5.3.2-1.fc19, qt5-qtserialport-5.3.2-1.fc19, qt5-qtsvg-5.3.2-1.fc19, qt5-qttools-5.3.2-1.fc19, qt5-qttranslations-5.3.2-1.fc19, qt5-qtwebkit-5.3.2-1.fc19, qt5-qtx11extras-5.3.2-1.fc19, qt5-qtxmlpatterns-5.3.2-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.