Bug 1154896 - Repeating kernel crashes
Summary: Repeating kernel crashes
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-21 01:48 UTC by Stephen Gallagher
Modified: 2014-10-21 13:07 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-21 13:07:06 UTC
Type: Bug


Attachments (Terms of Use)

Description Stephen Gallagher 2014-10-21 01:48:54 UTC
Description of problem:
The system appears to be running properly, but ABRT is notified of errors in kernel-core every few seconds.

Version-Release number of selected component (if applicable):
kernel-3.17.1-302.fc21

How reproducible:
I locked my screen for four hours and came back to 600+ ABRT messages.

Steps to Reproduce:
1. Unknown

Actual results:


Expected results:


Additional info:
Oct 20 10:04:13 sgallagh540.sgallagh.redhat.com abrt-server[1557]: Can't find a meaningful backtrace for hashing in '.'
Oct 20 10:04:13 sgallagh540.sgallagh.redhat.com abrt-server[1557]: Option 'DropNotReportableOopses' is not configured
Oct 20 10:04:13 sgallagh540.sgallagh.redhat.com abrt-server[1557]: Preserving oops '.' because DropNotReportableOopses is 'no'
Oct 20 10:04:13 sgallagh540.sgallagh.redhat.com abrt-server[1557]: Looking for kernel package
Oct 20 10:04:13 sgallagh540.sgallagh.redhat.com abrt-server[1557]: Kernel package kernel-core-3.17.1-302.fc21.x86_64 found
...
Oct 20 10:04:14 sgallagh540.sgallagh.redhat.com abrt-dump-journal-oops[1041]: Reported 1 kernel oopses to Abrt
...
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel: ------------[ cut here ]------------
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel: WARNING: CPU: 6 PID: 275 at drivers/gpu/drm/i915/intel_dp.c:1306 edp_panel_vdd_off.part.12+0x62/0x70 [i915]()
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel: eDP VDD not forced on
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel: Modules linked in:
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel:  rfcomm fuse ccm xt_CHECKSUM ipt_MASQUERADE tun nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_rpfilter ip6t_REJECT xt_conntrack ebtable_nat ebtable_b
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel:  shpchp snd_hda_controller snd_hda_codec mei_me mei snd_hwdep thinkpad_acpi tpm_tis snd_seq wmi tpm snd_seq_device rfkill snd_pcm snd_timer snd ie31200_eda
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel: CPU: 6 PID: 275 Comm: kworker/6:1 Not tainted 3.17.1-302.fc21.x86_64 #1
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel: Hardware name: LENOVO 20BFS0EC00/20BFS0EC00, BIOS GMET62WW (2.10 ) 03/19/2014
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel: Workqueue: events i915_hotplug_work_func [i915]
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel:  0000000000000000 000000001ffb98a8 ffff880036953c90 ffffffff8173dbb1
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel:  ffff880036953cd8 ffff880036953cc8 ffffffff81096e8d ffff880407c890e0
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel:  0000000000000000 ffff880036af0000 0000000000000011 0000000000000003
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel: Call Trace:
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel:  [<ffffffff8173dbb1>] dump_stack+0x45/0x56
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel:  [<ffffffff81096e8d>] warn_slowpath_common+0x7d/0xa0
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel:  [<ffffffff81096f0c>] warn_slowpath_fmt+0x5c/0x80
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel:  [<ffffffffa003ee5b>] ? drm_dp_dpcd_read+0x1b/0x20 [drm_kms_helper]
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel:  [<ffffffffa01b5ba2>] edp_panel_vdd_off.part.12+0x62/0x70 [i915]
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel:  [<ffffffffa01b62d0>] intel_dp_probe_mst.part.15+0xb0/0xf0 [i915]
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel:  [<ffffffffa01b8889>] intel_dp_detect+0xa9/0x230 [i915]
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel:  [<ffffffffa01711c8>] i915_hotplug_work_func+0x1f8/0x310 [i915]
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel:  [<ffffffff810af66d>] process_one_work+0x14d/0x400
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel:  [<ffffffff810afffb>] worker_thread+0x6b/0x4a0
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel:  [<ffffffff810aff90>] ? rescuer_thread+0x2a0/0x2a0
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel:  [<ffffffff810b50da>] kthread+0xea/0x100
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel:  [<ffffffff810b4ff0>] ? kthread_create_on_node+0x1a0/0x1a0
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel:  [<ffffffff81744c7c>] ret_from_fork+0x7c/0xb0
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel:  [<ffffffff810b4ff0>] ? kthread_create_on_node+0x1a0/0x1a0
Oct 20 11:13:02 sgallagh540.sgallagh.redhat.com kernel: ---[ end trace 73c746582c31c485 ]---

Comment 1 Josh Boyer 2014-10-21 11:09:59 UTC
These are warnings, not crashes.

What kind of machine is this and in what configuration?

Comment 2 Stephen Gallagher 2014-10-21 12:48:54 UTC
Created attachment 948945 [details]
Output of lshw

Hmm, looks like I may have been mistaken about it only affecting this kernel. I found this in abrt-cli:

id dd2bff3cc92ba66873d3c8515ae82dc7d2f26d68
reason:         WARNING: CPU: 6 PID: 27240 at drivers/gpu/drm/i915/intel_dp.c:1306 edp_panel_vdd_off.part.12+0x62/0x70 [i915]()
time:           Tue 14 Oct 2014 12:04:50 AM EDT
cmdline:        BOOT_IMAGE=/vmlinuz-3.17.0-301.fc21.x86_64 root=/dev/mapper/fedora_dhcp--25--221-root ro rd.lvm.lv=fedora_dhcp-25-221/root rd.lvm.lv=fedora_dhcp-25-221/swap vconsole.font=latarcyrheb-sun
16 rd.luks.uuid=luks-782c290c-fbb7-4db9-a8bf-90d4f04911c5 rhgb quiet LANG=en_US.utf8
package:        kernel
count:          6906
Directory:      /var/tmp/abrt/oops-2014-10-14-00:04:50-932-0


(That count is horrific...) It looks like I've been seeing it since 3.17.0 though.


My system is a Lenovo T540p (lshw output also attached):

00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor DRAM Controller (rev 06)
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
00:16.3 Serial controller: Intel Corporation 8 Series/C220 Series Chipset Family KT Controller (rev 04)
00:19.0 Ethernet controller: Intel Corporation Ethernet Connection I217-LM (rev 04)
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d4)
00:1c.1 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #2 (rev d4)
00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d4)
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QM87 Express LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 04)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5227 PCI Express Card Reader (rev 01)
04:00.0 Network controller: Intel Corporation Wireless 7260 (rev 83)

Comment 3 Adam Jackson 2014-10-21 12:51:18 UTC
"Every few seconds" sounds like some kind of hotplug interrupt is getting repeatedly triggered.  Do you see the same stream of warnings without X running?

Comment 4 Stephen Gallagher 2014-10-21 13:07:06 UTC
I'm not experiencing it right now, but your comment makes me suspect why that might be; I have a USB KVM switch at home that I have suspicions is faulty. (When it's connected to my Windows Server test machine, I occasionally start hearing disconnect/reconnect chimes constantly). I suspect that's the actual cause of this issue.

It's odd that ABRT wasn't picking it up until the recent kernel, though.

I'm going to close this BZ and assume that it's caused by the faulty hardware unless I experience it again without that connected.


Note You need to log in before you can comment on or make changes to this bug.