Bug 115492 - partition definition errors
partition definition errors
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-12 19:24 EST by Gene Czarcinski
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 11:46:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2004-02-12 19:24:26 EST
Description of problem:

I am trying to install on a Maxstor 5T060H6 (60GB) ide drive.  With
FC1 (and RHL9), there were no problems.  However, booting up the FC2
test1 installer (nfs install), I get popup errors about partition
boundries being wrong and when I finally get to druid, the layout does
not seem to recognize LBA values.

Version-Release number of selected component (if applicable):
FC2 test1


From FC1 fdisk -l /dev/hda:

Disk /dev/hda: 61.4 GB, 61492838400 bytes
255 heads, 63 sectors/track, 7476 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
 
   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1      1275  10241406    c  Win95 FAT32 (LBA)
/dev/hda2          1276      1525   2008125   82  Linux swap
/dev/hda3          1526      1650   1004062+  83  Linux
/dev/hda4          1651      7476  46797345    5  Extended
/dev/hda5          1651      2867   9775521   83  Linux
/dev/hda6          2868      4084   9775521   83  Linux
/dev/hda7          4085      5301   9775521   83  Linux
/dev/hda8          5302      6518   9775521   83  Linux
/dev/hda9          6519      7476   7695103+  83  Linux

I have FC1 and RHL9 installedin hda5 and hda6 respectively.  I was
planning to pu FC2 into hda7.
Comment 1 Gene Czarcinski 2004-02-13 05:08:40 EST
It is interesting that there is an identical Maxtor 5T060H6 as hdb and
the LBA values are correct for it.
Comment 2 Gene Czarcinski 2004-02-13 09:48:33 EST
OK, I got an everything install done by speciying hda=7476,255,63 as a
boot kernel parameter.

After install, I ran parted /dev/hda print and it indicated errors
whereas parted /dev/hdb print was OK.

his leads me to believe that the problem is with parted.
Comment 3 Gene Czarcinski 2004-02-29 13:46:33 EST
Also see https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=113201
Comment 4 Jeremy Katz 2004-04-15 00:56:52 EDT
parted should be happier now as of the 1.6.9-2
Comment 5 Gene Czarcinski 2004-04-15 01:04:44 EDT
I do not see the change.  kernel-smp-2.6.5-1.322, parted-1.6.9.2


[root@chaos root]# parted /dev/hdb print
Disk geometry for /dev/hdb: 0.000-58644.140 megabytes
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
1          0.031   5004.624  primary   ext3        boot
2       5004.624  58643.525  extended
5       5004.655   9005.185  logical   ext3
6       9005.216  13005.747  logical   ext3
7      13005.778  23007.150  logical   ext3
8      23007.182  33008.554  logical   ext3
9      33008.585  53011.362  logical   ext3
10     53011.393  58643.525  logical   fat32
Information: Don't forget to update /etc/fstab, if necessary.
                                                                     
          
[root@chaos root]# parted /dev/hda print
Warning: Unable to align partition properly.  This probably means that
another
partitioning tool generated an incorrect partition table, because it
didn't havethe correct BIOS geometry.  It is safe to ignore,but
ignoring may cause
(fixable) problems with some boot loaders.
Ignore/Cancel? i
Disk geometry for /dev/hda: 0.000-58644.140 megabytes
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
1          0.031  10001.403  primary   fat32       boot, lba
2      10001.404  11962.463  primary   linux-swap
3      11962.463  12942.993  primary   ext3
4      12942.993  58643.525  extended
5      12943.024  22489.431  logical   ext3
6      22489.462  32035.869  logical   ext3
7      32035.900  41582.307  logical   ext3
8      41582.338  51128.745  logical   ext3
9      51128.776  58643.525  logical   ext2
Information: Don't forget to update /etc/fstab, if necessary.

The drives are identical.
Comment 6 Gene Czarcinski 2004-04-16 10:37:02 EDT
Oops ... things have gone from bad to worse.

I just tried to do an install based on a snapshot of development from
15 April (x64_86).  Aside from the fact that it bombed because of an
selinux related traceback, the partitioning for hda (no windows
involved) is not screwed up too (same business about unaligned
partitions).  hda had been OK with LBA.  I can override at boot time
with hda=14946,255,63 but I should not need to do this.  The attached
SATA drive is still bad too.

Both drives were originally partitioned with FC1.  hda was initially
partitioned with anaconda/parted by FC1 i386 install and then
partitions added with fdisk.  /dev/sda was partitioned with fdisk
under FC1 x86_64 and becomes hde under FC2T1/FC2T2.

Note You need to log in before you can comment on or make changes to this bug.