Bug 115498 - scripts/mkdep: Argument list too long
scripts/mkdep: Argument list too long
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Depends On:
  Show dependency treegraph
Reported: 2004-02-12 20:49 EST by Bill Rugolsky, Jr.
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-29 16:05:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Patch to fix argument list too long error. (728 bytes, patch)
2004-02-12 20:54 EST, Bill Rugolsky, Jr.
no flags Details | Diff

  None (edit)
Description Bill Rugolsky, Jr. 2004-02-12 20:49:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)

Description of problem:
If one increases the number of files passed to mkdep when creating a
custom kernel, the use of find in shell backquotes results in
an argument list too long error:

/bin/sh: line 1: scripts/mkdep: Argument list too long

Solution: use xargs. I've attached a patch against 2166.
It includes the -r argument to xargs, which is technically
correct, but not supported on all platforms (e.g., Solaris).

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Add some files. (I added Netfilter p-o-m and a few other modules.)
2, Build the kernel.

Actual Results:  /bin/sh: line 1: scripts/mkdep: Argument list too long

Additional info:
Comment 1 Bill Rugolsky, Jr. 2004-02-12 20:54:56 EST
Created attachment 97636 [details]
Patch to fix argument list too long error.
Comment 2 Robin 2004-08-09 11:49:26 EDT
Having run into this problem on numerous occasions and just recently
causing me a major headache I did some searching.

There seems to be an argument limit is the kernel that prevents
passing to many files names to various functions.  There are many work
arounds that sometimes work but many times don't.

This is going to increase the number of headaches for many users as
more and more users are starting to process a larger number of files.
 This needs to be fixed.

If you have alot of files to mv, rm or process, you run into a limit.
 In the case of rm or mv, it is possible to put wildcards into the
command to limit the number of files being processed at one time. 
Other applications don't work as well.

I ran into this problem with PAN and a mpg file I was trying to
download.  The file had 1510 attachments that needed to be ydecoded
and pan would just stop processing the file.   I saved the text files
for each attachment and then procedded to process the files by typing
in ydecode * and received the "Argument list too long" message.

I searched the net and found that there is a change to the kernel that
can fix this problem but you have to re-compile the kernel.  I don't
want to do this on all my machines.  It may be a good idea to increase
this argument on all future kernels.

I am using FC1 and will update to FC3 when it is out.  I hope that
this is fixed then.

Suggested enhancement as well as a major headache.
Comment 3 Dan Kegel 2004-09-03 10:36:35 EDT
I ran into this on stock 2.6.8 for arm, so it really needs fixing.
Probably with xargs, though I haven't looked at it...
Comment 4 Dan Kegel 2004-09-03 10:39:50 EDT
Err, it was stock 2.4.26 I ran into this on.
And I didn't see the patch attached to the previous comment;
I'll try that out now.
Comment 5 David Lawrence 2004-09-29 16:05:34 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.