Bug 1154991 - mpich: fortran modules PATH incorrect
Summary: mpich: fortran modules PATH incorrect
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mpich
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zbigniew Jędrzejewski-Szmek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-21 08:13 UTC by marcindulak
Modified: 2015-12-06 19:20 UTC (History)
4 users (show)

Fixed In Version: mpich-3.1.4-7.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-06 19:20:22 UTC


Attachments (Terms of Use)

Description marcindulak 2014-10-21 08:13:20 UTC
Description of problem:

According to http://fedoraproject.org/wiki/Packaging:MPI
the "MPI stack specific Fortran" modules should be under
MPI_FORTRAN_MOD_DIR	%{_fmoddir}/%{name}%{?_opt_cc_suffix}/

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. module load mpi/mpich-x86_64
2. echo $MPI_FORTRAN_MOD_DIR
3.

Actual results:

/usr/include/mpich-x86_64

Expected results:

/usr/lib64/gfortran/modules/mpich

Additional info:

Similar problem on 32-bit. The problem is present also on RHEL6 and RHEL7.
The analogous problem is present also for openmpi (bug #1154982).

Note also a discussion in bug #983057

Comment 1 Susi Lehtola 2015-02-13 20:39:50 UTC
Any progress?

Comment 2 Jaroslav Reznik 2015-03-03 16:23:13 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 3 marcindulak 2015-11-08 14:18:41 UTC
A fix has to backported to EPEL too.
The longer we wait the more spec files need to be fixed.
See also bug #1154982

Comment 4 Fedora Update System 2015-11-16 18:41:12 UTC
mpich-3.1.4-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-be322c3755

Comment 5 Orion Poplawski 2015-11-16 20:15:33 UTC
Still inconsistent with 3.1.4-8;

MPI_FORTRAN_MOD_DIR=/usr/lib64/gfortran/modules/mpich-x86_64

Installed into /usr/lib64/gfortran/modules/mpich

Comment 6 Fedora Update System 2015-11-18 16:52:48 UTC
mpich-3.1.4-7.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update mpich'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-be322c3755

Comment 7 Zbigniew Jędrzejewski-Szmek 2015-11-18 16:58:07 UTC
MPI_FORTRAN_MOD_DIR is fixed in 3.1.4-9.fc24, 3.1.4-7.fc23.

Comment 8 Orion Poplawski 2015-11-21 00:11:33 UTC
Indeed, seems to work now.  Thanks.

Comment 9 Fedora Update System 2015-12-06 19:20:14 UTC
mpich-3.1.4-7.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.